[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum Kernel Dependency error



On Tue, 2006-02-14 at 08:23 +0300, Systems Administrator wrote:
> --> Finished Dependency Resolution
> Error: Missing Dependency: kernel = 2.6.14-1.1653_FC4 is needed by package cman-kernel
> Error: Missing Dependency: /lib/modules/2.6.14-1.1653_FC4 is needed by package dlm-kernel
> Error: Missing Dependency: kernel = 2.6.14-1.1653_FC4 is needed by package dlm-kernel
> Error: Missing Dependency: /lib/modules/2.6.14-1.1653_FC4 is needed by package gnbd-kernel
> Error: Missing Dependency: kernel = 2.6.14-1.1653_FC4 is needed by package gnbd-kernel
> Error: Missing Dependency: kernel = 2.6.14-1.1653_FC4 is needed by package GFS-kernel
> Error: Missing Dependency: /lib/modules/2.6.14-1.1653_FC4 is needed by package cman-kernel
> Error: Missing Dependency: /lib/modules/2.6.14-1.1653_FC4 is needed by package GFS-kernel
> 
> Is there a solution to the above error??

Yes, there is. This comes up regularly.

# rpm -e cman-kernel dlm-kernel gnbd-kernel GFS-kernel

These kernel modules regularly get out of step with the main kernel,
causing dependency problems. Unless you're using GFS (and if you don't
know what it is, you almost certainly won't be doing), you can safely
remove these modules.

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]