[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problem booting - what should I have done?



I had a curious problem booting my desktop the other day.
(I only boot it on very rare occasions.)
It is a SCSI machine, with an additional IDE disk.
Basically, udev did not create /dev/hda (as far as I can see)
so the IDE disk, which was mentioned in /etc/fstab , could not be opened.

As a result, the boot failed, and the machine sank
to single-user mode.

I wanted to edit /etc/fstab , but the root partition
was mounted read-only, so I could not do this.

In the end, I run knoppix, and edited it that way,
and the problem was solved.

(I tried both the FC-4 rescue CD, and FC-4 CD#1,
but neither worked as they said they could not read the CD,
despite the fact that they were reading it.
However, that is a different issue
which I asked about here without getting an answer.)

My question is whether there was something simpler I could have done?


-- 
Timothy Murphy  
e-mail (<80k only): tim /at/ birdsnest.maths.tcd.ie
tel: +353-86-2336090, +353-1-2842366
s-mail: School of Mathematics, Trinity College, Dublin 2, Ireland


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]