[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Hard drive cable question -



Mike McCarty wrote:

bobgoodwin wrote:

Mike McCarty wrote:

bobgoodwin wrote:


[snip]

If you use M/S jumpering on the drives, then in theory it doesn't matter
where you connect them.



Except it appears to me that it matters as far as terminating the line properly is concerned. Ideally it would seem the termination should be at the far end where the master is connected to avoid the possibility of a mismatch at the end of the stub that would result if the slave is at the far end. How much ringing might occur and the severity of it's effect is an unknown? It would be interesting if I could get into the circuit and poke around with a scope probe ...


Agreed.

[snip]


I thought "cable select" cables had wires obviously crossed in the ribbon cable but that may not be true with this 80 wire ribbon?


Not crossed. For CS, the drives have resistive pull-ups on them. The MB
pulls down one line. The wire to this line is *severed* as the slave
connector, so the "master" sees a high, while the "slave" sees
a low on this pin. (The MB may have a pull-up and the drives
a pull-down, I forget the polarity.)

If the h/d manufacturer provided this explanation this thread would never have started. I would have never asked any questions. It appears


Well, just how much of the interface should they document? Each pin?
Just the Cable Select pin?

that I probably have cable select which I will try here in a little while. The drives can be jumpered for CS and I have 80 wire ribbon cables so it appears that should work if I understand everything I've read here? It would be helpful if the user knew that he was dealing with a c/s cable, there is no mark apparently other than the fact that there are more wires than connector pins to tie them to?


Color of the connectors. Usually non-CS cables use just one color
of connector, presumably because they can get better volume
prices that way. CS cables are supposed to use blue for the MB
connector, black for "master" and grey for "slave", IIRC.

Mike

Ok, I jumpered the drives c/s and the computer can deal with that. As long as the one set up for FC4 is on the master connector it boots and I can see the second drive.

The problem arose from the fact that I suspected an intermittent drive problem. Apparently the failure was on the Windows drive while I was only using FC4 and MySql! I ran smartctl and it indicated that both drives had a lot of use on them. One looked like more than four years power on time! I assumed it was the bad drive and rep[laced it with another low time drive I had and then I began to have trouble. The computer would not boot no matter what I tried.

Now I pulled the one I thought to be usable [but is bad, I just tried it again] and replaced it with the "bad" drive I had set aside and the computer will boot FC4 with that drive plugged into the c/s master connector. Hwbrowser and fdisk show both drives. So next to start over and install W2k on the other drive, I guess Windows will want to be the master and I will most likely wind up reinstalling FC4 with grub in the MBR on the Windows drive.

If nothing else I have learned something about configuring hd and their jumpers ...

The information has been helpful and appreciated.

BobG



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]