[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC5 - Intel 945GM not working



I installed the latest Fedora Core 5 and upgraded the kernel yesterday:
Did you update xorg stuff as well ?
Or all updates ?

yea, updated everything.

(II) I810: Driver for Intel Integrated Graphics Chipsets: i810,
i810-dc100,
        i810e, i815, i830M, 845G, 852GM/855GM, 865G, 915G, E7221 (i915),
        915GM, 945G
(II) Primary Device is: PCI 00:02:0
(--) Assigning device section with no busID to primary device
(WW) I810: No matching Device section for instance (BusID PCI:0:2:1)
found
(EE) No devices detected.

Fatal server error:
no screens found

does anyone know how to fix that?
Looking at: http://wiki.x.org/wiki/FAQErrorMessages section 1.7.1,
Either the driver set is not the correct driver or it is the best fit
but not yet supported.
I see the i810 mentions 945G but not 945GM. They might be close enough
to be able to hack the detection into thinking you have a 945 ?

Is the graphics chip in pci-ids.txt:
# lspci -v -s 00:02.1
What is the pci-id ?
# lspci -n -s 00:02.1

# lspci -v -s 00:02.1
00:02.1 Display controller: Intel Corporation Mobile Integrated Graphics Controller (rev 03)
        Subsystem: Samsung Electronics Co Ltd Unknown device c504
        Flags: fast devsel
        Memory at d8180000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: [d0] Power Management version 2

# lspci -n -s 00:02.1
00:02.1 0380: 8086:27a6 (rev 03)

Coming into this late, but this may help. What I did on my Toshiba
laptop to make it work was to get i915-20060403-linux.i386.tar.bz2
from http://dri.freedesktop.org/snapshots/. Make sure you only
install that file, and not the common-20060403-linux.i386.tar.bz2
file, or you will break things. (I ended up with a blank screen and
had to get rid of the files from
common-20060403-linux.i386.tar.bz2.) You then pick the i810 driver.
It gives you much better video then using the VESA driver. You are
installing a replacement i810 and an i915 module.

I just downloaded i915-20060403-linux.i386.tar.bz2 and installed it and it works replacing "vesa" driver with "i810", thanks alot! I setup xorg with external monitor using the Xinerama option. But it seems that 3D acceleration is not working:

# glxinfo | grep rendering
direct rendering: No

is that because of the Xinerama option or do I have to enable something in my xorg.conf to enable direct rendering?

Marcel


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]