[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

ACPI and hotplug issues on a Dell laptop



I’ve used slack for years, mainly because when I first started with linux it was one of the few distros that came compiled for the 386 or 486 I had to dedicate to the project. And you know how loyalty goes with distros, once you start with one and it works…

 

Two years ago or so I dug up a Dell Latitude CSx. I upgraded the memory to 256M and it already had a 12G HD. It’s a P3. Not a bad box for linux.

 

Naturally I put slack on it and was surprised to see how everything just worked (except sound, but that wasn’t high on my list). ACPI worked great, even using the special dell keys, suspend the box, close it – boom it sleeps like a charm. Open the laptop and it wakes right back up.

 

Hotplug was the same. I bought a USB linksys 10/100 nic, plugged it in and it loaded the drivers right up, unplug it, no problems at all.

 

I may have had to do some tinkering, like maybe enable one acpi instead of the default or make sure the hotplug kernel module was loaded. It was so long ago I can’t really remember. All in all it was very painless.

 

Then Fedora 5 came out. I’ve been using fedora off and on with a number of desktops and though it would be nice to try it on the laptop. I bought a 60G HD and figured now is as good a time as any.

 

I’m sad to report it doesn’t work as good as slack. It looks nicer. It “feels” smoother. But as far as functionality goes slack 9.1 (released Sept of ’03) beats FC5, just released.

 

With fc5 when I would suspend (either with dell’s button or from the gnome menu) it would say “Suspending =======…” and I would get an error indication that a module or running process couldn’t be suspended but it would go ahead and suspend. When I would re-activate the same “Suspending ====” screen would pop up, then the screen would black out and the system would freeze. Total lockup even though the power light is on. I went through the rc.d scripts and turned off everything that I didn’t need, tried it again and it worked intermittently. I didn’t get the message that a process couldn’t be suspended, but it would lock up the same when it was waking up.

 

The usb hotplug doesn’t work well either. Everything is ok if you plug the device in and never take it out. As soon as you take it out the system locks up. Mouse won’t move, etc…

 

I’d really like to stay with fc5 if I can clear these issues up and have the time and patience to work with it. But I just don’t know where to start. I’ve googled but the most I’ve found are just other people complaining about similar problems and not really any fixes (other than announcements that fc5 would fix sleep/awake problems with dells).

 

All suggestions are welcome.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]