[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: strange thing



On Fri, 2006-05-05 at 12:55 +0200, Tatxe wrote:
> Hi all..
> 
> I'm trying to use PHP in FC5 with apache, but there's something strange.
> (I have the php.ini with error_reporting  =  E_ALL and  display_errors =
> On)
> 
> I wrote a page like.
> 
> <?
> echo  "pepote";
> ?>
> And shows fine in http://localhost.
> 
> But if i use:
> <?
> phpinfo();
> ?>
> Nothing happens,well, in fact, the browsers seems to be waiting for
> something.
> 
> If I do by command (php index.php) all seems fine and I can see all the
> information that shows the phpinfo(), command...
> 
> Anybody with any idea about what i'm doing wrong...
> 
> By the way, the logs don't show anything usual.
> error_log
> [Fri May 05 12:46:04 2006] [notice] suEXEC mechanism enabled
> (wrapper: /usr/sbin/suexec)
> [Fri May 05 12:46:04 2006] [notice] Digest: generating secret for digest
> authentication ...
> [Fri May 05 12:46:04 2006] [notice] Digest: done
> [Fri May 05 12:46:04 2006] [notice] Apache/2.2.0 (Fedora) configured --
> resuming normal operations
> 
> access_log
> 127.0.0.1 - - [05/May/2006:12:46:40 +0200] "GET /index.php HTTP/1.1" 200
> 49669 "-" "Mozilla/5.0 (X11; U; Linux i686; es-ES; rv:1.8.0.2)
> Gecko/20060419 Fedora/1.5.0.2-1.2.fc5 Firefox/1.5.0.2 pango-text"

Do you have SELinux enabled? Are there any denials in /var/log/messages?

You usually need to enable the httpd_builtin_scripting selinux boolean
to use PHP in FC5.

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]