[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum update on FC5 install new kernel but don't update grub.conf



Ambrogio wrote:
Il giorno mar, 09/05/2006 alle 07.47 +0200, Ambrogio ha scritto:
Ok, but noone talk about the first problem.

What is wrong is that
rpm -ivh kernel-2.6.16-1.2111_FC5.x86_64.rpm
kernel-devel-2.6.16-1.2111_FC5.x86_64.rpm
Preparing...                ###########################################
[100%]
        package kernel-devel-2.6.16-1.2111_FC5 is already installed
        package kernel-2.6.16-1.2111_FC5 is already installed

and
rpm -e kernel-2.6.16-1.2111_FC5.x86_64.rpm
kernel-devel-2.6.16-1.2111_FC5.x86_64.rpm
error: package kernel-2.6.16-1.2111_FC5.x86_64.rpm is not installed
error: package kernel-devel-2.6.16-1.2111_FC5.x86_64.rpm is not installed

no solution about that?
I think is not a problem related to disk spaces because yum check for
space requirement.

Maybe a rpm database's corruption.

No, it's user error.
"rpm -i" takes a FILENAME as argument - this you are doing correctly.
"rpm -e" takes a PACKAGE NAME as argument - you are giving a filename.

You have the packages already installed. To remove them:
# rpm -e kernel-2.6.16-1.2111_FC5.x86_64 kernel-devel-2.6.16-1.2111_FC5.x86_64

I can try with --force but I want to check other way before.

Never use --force or --nodeps unless you *really* know what you're doing.

Paul.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]