[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fc5 and gcc4.1 compiler problems



well, i suppose vertices is present. the package has the needed build libraries / headers bundled and compiles smoothly on an fc4 with the gcc4.0. it just won't compile on my fc5 with the 4.1. i will have a look at the gcc site you mentioned ... we will see if it will work...

On 5/12/06, Jakub Jelinek <jakub redhat com> wrote:
On Fri, May 12, 2006 at 08:34:09AM +0200, Johannes Rainer wrote:
> interfaces.cpp:371:   instantiated from here
> boostIncl/boost/graph/depth_first_search.hpp:324: error: no matching
> function for call to 'vertices(const std::vector<std::vector<long unsigned
> int, std::allocator<long unsigned int> >, std::allocator<std::vector<long
> unsigned int, std::allocator<long unsigned int> > > >&)'
>
> unfortunately it is not my code, so i have no clue how to fix the problem if
> it is a bug in the source code. it's just interesting that it compiles fine
> with gcc3.2, gcc4.0 but not with gcc4.1 ...

Please see http://gcc.gnu.org/gcc-4.1/changes.html , there were some C++
frontend changes in GCC 4.1 and this might very well be one of them.
Primarily check if vertices is present in a friend decl but without a real
decl.

        Jakub

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list



--
Johannes Rainer, Msc
Tyrolean Cancer Research Institute
Innrain 66, 6020 Innsbruck, Austria
Tel.: +43 512 570485 15
Email: johannes rainer tcri at
          johannes rainer tugraz at
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]