[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: fc5 and gcc4.1 compiler problems



no, i haven't tried that, but now i have ;) thanks to your suggestion, but it didn't help. i get the same error. it must have to do with the gcc4.1 compiler (or FC5), because on FC4 with the gcc4.0 the same package compiles. actually i have also tried to compile it with the g++32 instead of the g++, but this also failed.
any suggestions?


On 5/12/06, Markku Kolkka <markkuk tuubi net> wrote:
Johannes Rainer kirjoitti viestissään (lähetysaika perjantai, 12.
toukokuuta 2006 09:34):
> g++ -I/usr/local/lib64/R/include -I/usr/local/lib64/R/include
> -I/usr/local/include  -IboostIncl  -fpic  -g -O2 -c
> interfaces.cpp -o interfaces.o
> boostIncl/boost/graph/depth_first_search.hpp: In function
> 'void boost::depth_first_search(const VertexListGraph&, const
> boost::bgl_named_params<P, T, R>&) [with VertexListGraph =
> std::vector<std::vector<long unsigned int, std::allocator<long
> unsigned int>
> ...

I get the impression that your package uses its own copy of Boost
headers instead of the FC5 ones. Have you tried installing
boost-devel and configuring the software to
use /usr/include/boost instead of "boostIncl"?

--
Markku Kolkka
markku kolkka iki fi

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list



--
Johannes Rainer, Msc
Tyrolean Cancer Research Institute
Innrain 66, 6020 Innsbruck, Austria
Tel.: +43 512 570485 15
Email: johannes rainer tcri at
          johannes rainer tugraz at
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]