[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Exact kernel-devel -- headers



Gowri wrote:
> Hi all ,
> 
> some time back i have installed FC4 and kernel-devel ( headers) , for
> building and loading kernel modules.
> 
> Things were working fine ,
> 
> In recent days , i deleted the kernel-devel ( headers ) by mistake .
> 
> i tried to install again kernel-devel headers using command "yum install
> kernel-devel-2.6.11 . 
> it got installed but when i try to build and  insert module ,
> It is giving an error 
>     "invalid  module format"
> 
> I have verfied in /var/log/messages it is giving a message
> "disagrees about version of symbol struct_module "
> 
> when i type uname -r  its output is  2.6.11-1.1369_FC4smp.
> 
> installed kernel-devel directory name is 2.6.11-1.1369_FC4-i686.
> 
> 
> How i can download the exact kernel-devel headers ?
> 
> Any pointers will be helpfull.

It appears you are running an SMP kernel but you loaded the devel
packages for the UP kernel.

kernel-smp-devel

I what you want


-- 
You have a reputation for being thoroughly reliable and trustworthy.
A pity that it's totally undeserved.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]