[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: VMware server cannot run on FC6

On 10/26/06, Frank Pineau <frank pineaus com> wrote:
> rpm -q --queryformat "%{name}-%{arch}\n" kernel
> What we did was to download the i686 kernel and kernel-devel from an
> http mirror, then
> rpm -e --nodeps kernel kernel-devel
> (don't worry about the grubby warning)  then added back in the i686
> stuff we just downloaded
> rpm -i kernel*.rpm
> On reboot, the previously compiled module "just worked" without a
> recompile, now it had an i686 arch kernel to get into.
> -Andy

FWIW: I ran into this same problem on my computer.  Following this same
procedure did, in fact, get the kernel installed, but it never updated
grub.conf.  It removed the old entry, but didn't add the new one.
Luckily, I'd been watching this thread and made sure it was set before I

I think 'rpm -i kernel*' does not install the kernel (contrary to what
was expected), as the command:

rpm -qa | grep kernel

returns nothing (in rescue mode).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]