[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Flow control is off for TX ...



Hi,

We had a problem with our FC6 system's network. Since today early morning,
the system hangs (I could not logon even locally) until I forced shut it
down and restarted.

The system information:
kernel -- 2.6.20-1.2952.fc6
one network card on a 100Mbs network line, pretty new pc.

The system log shows:

Aug  1 04:48:17 morpheus kernel: tg3: eth0: Link is down.
Aug  1 04:48:59 morpheus kernel: tg3: eth0: Link is up at 100 Mbps, full
duplex.
Aug  1 04:48:59 morpheus kernel: tg3: eth0: Flow control is off for TX and
off for RX.
... (repeat until I shut it down at around 8am)

I checked the earlier logs and found there was similar message on July 28,
but just one entry and at that time the system didn't hang -- seems
"recovered" to normal and so I didn't realize the problem.
Now, the system seems working normal. Below are some other information:

# netstat -in
Kernel Interface table
Iface       MTU Met    RX-OK RX-ERR RX-DRP RX-OVR    TX-OK TX-ERR TX-DRP
TX-OVR Flg
eth0       1500   0    12752      0      0      0    13363      0      0
   0 BMRU
lo        16436   0    38734      0      0      0    38734      0      0
   0 LRU

# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:16:76:25:95:3F
          inet addr:128.252.85.129 Bcast:128.252.85.255 Mask:255.255.255.0
          inet6 addr: fe80::216:76ff:fe25:953f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:98052 errors:0 dropped:0 overruns:0 frame:0
          TX packets:106395 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:29156234 (27.8 MiB)  TX bytes:54961336 (52.4 MiB)
          Interrupt:20

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:81565 errors:0 dropped:0 overruns:0 frame:0
          TX packets:81565 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:60332142 (57.5 MiB)  TX bytes:60332142 (57.5 MiB)

I installed packages that all from yum, nothing from other sources.

I can restart network service w/o any problem -- I can't repeat the above
error message myself.

Can somebody tell me what the above message mean? Hardware problem or
system problem? How to fix it?

Thanks for all help!

Hongwei Li


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]