[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Qemu, Networking and F7



On Thu, Aug 02, 2007 at 11:07:11AM +0000, Kevin Kofler wrote:
> Charles Curley <charlescurley <at> charlescurley.com> writes:
> > Has anyone got qemu working on F7 with networking? I've googled and
> > read the docs, but nothing I've tried produces a working network.
> 
> I just use the default userspace NAT emulation.

What "default userspace NAT emulation"?

> 
> QEMU can talk to the network with no switches at all, the traffic will be NATed 
> to host ports in userspace. If you want to be able to connect _to_ QEMU, you 
> can use the -redir switch to map the guest port to a host port:
> -redir tcp:host_port::guest_port
> For example, guest_port can be 22 for ssh, then you can SSH in with ssh 
> 127.0.0.1 -p host_port (of course you have to pick a free port number for 
> host_port).

I tried this:

qemu -boot d -hda test.img -cdrom /crc/isos/finnix/finnix-89.1.iso

I then ran ifconfig on the virtual machine to assign an IP
address. Ping fails.

What am I missing? I have no XEN virtualization packages installed.

-- 

Charles Curley                  /"\    ASCII Ribbon Campaign
Looking for fine software       \ /    Respect for open standards
and/or writing?                  X     No HTML/RTF in email
http://www.charlescurley.com    / \    No M$ Word docs in email

Key fingerprint = CE5C 6645 A45A 64E4 94C0  809C FFF6 4C48 4ECD DFDB

Attachment: pgpzaliq0mGiS.pgp
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]