[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

SATA DVD not working - failed to set xfermode (err_mask=0x4)



I recently bought a SATA Pioneer DVR-212D drive and fitted it to my (64 bit) Fedora 7 system. On boot I get the following error (it also appears when dmesg is run):

  ata4.00: failed to set xfermode (err_mask=0x4)

The full dmesg output for ata4 is at the bottom of this post.

I have Googled the problem and found plenty of references to it, but nothing that sounds like a solution. Especially for F7.

Can anyone shed any light on this problem for me?  System specs:

- CPU: Intel Core 2 Duo e6600
- Motherboard: Gigabyte GA-965P-DQ6
- Kernel 2.6.22.1.3225.fc7.x86_64

dmesg output for ata4:

ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata4.00: ATAPI: PIONEER DVD-RW  DVR-212, 1.21, max UDMA/66
ata4.00: qc timeout (cmd 0xef)
ata4.00: failed to set xfermode (err_mask=0x4)
ata4: failed to recover some devices, retrying in 5 secs
ata4: port is slow to respond, please be patient (Status 0x80)
ata4: COMRESET failed (errno=-16)
ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata4.00: qc timeout (cmd 0xef)
ata4.00: failed to set xfermode (err_mask=0x4)
ata4.00: limiting speed to UDMA/66:PIO3
ata4: failed to recover some devices, retrying in 5 secs
ata4: port is slow to respond, please be patient (Status 0x80)
ata4: COMRESET failed (errno=-16)
ata4: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata4.00: qc timeout (cmd 0xef)
ata4.00: failed to set xfermode (err_mask=0x4)
ata4.00: disabled

Langdon


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]