[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

SOLVED: nVidia geforce fx 5200 (PCI) and agpgart problems on intel DQ965GF running Fedora FC7



PROBLEM

I've got a new box, it's got a intel DQ965GF mobo, with 2 SATA disks
(LVM) and came with Fedora 2.6.22.1-41.fc7 running on it. I wanted to
put my old nVidia geForce fx 5200 (PCI card) into it to allow me to use
both my TFTs. However, when I do this it gets to the GRUB menu, starts
to load a kernel (is that the right phrase) and then falls over. If I
leave the card in but tell the BIOS to use the internal graphics it
boots okay. But when return BIOS to auto detect or explicitly use the
nVidia card it falls over during boot. I've tried appending
 acpi=off
 pci=nommconf
at the end of the GRUB boot command but with no success. Generally the
failure messages say (at about the time there's agpgart messages):
  general protection fault 0000[1] SMP

WORKING SOLUTION

After much messing about, I've discovered that appending
 agp=off
allows me to boot into runlevel 3 with the nVidia card installed. It therefore appears there's some problem within (Fedora's?) agpgart (?) when nVidia card is chosen.


I then download the nVidia geForce FX 5200 driver from nVidia web site for 64bit machine:
  http://www.nvidia.com/object/linux_display_amd64_100.14.11.html
& as root, run the downloaded script
  NVIDIA-Linux-x86_64-100.14.11-pkg2.run

it had to build a module.
& I let it create a xorg.conf

Then run 'startx' and it boots into X

& menu item: applications->system tools->nVidia X server settings
gives user access to various options

One also has to amend the GRUB menu.lst so as to do 'agp=off' on future reboots.

Quite straightforward once the culprit (agp) has been identified!

I hope this is useful to others having problems (hence the rename of subject & x-posting), although I suspect it may be a Fedora kernel issue rather than anything more general

Michael Bane
Univ of Manchester, UK


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]