[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ipw3945-kmdl-2.6.22.1-32.fc6 needs /boot/vmlinuz-2.6.22.1-32.fc6, this is not available



>
> In case this helps:
> # rpm -qa | egrep '(kernel|kmdl|3945|ieee802)'
> kernel-devel-2.6.20-1.2962.fc6
> ipw3945d-1.7.22-4.at
> ieee80211-kmdl-2.6.20-1.2962.fc6-1.2.18-20.fc6
> ipw3945-kmdl-2.6.20-1.2962.fc6-1.2.0-18.4.fc6
> yum-plugin-kmdl-0.7-9.fc6
> kernel-headers-2.6.22.2-42.fc6
> fuse-kmdl-2.6.22.1-32.fc6-2.7.0-3_7.fc6
> ieee80211-1.2.18-20.fc6
> ieee80211-kmdl-2.6.22.1-32.fc6-1.2.18-20.fc6
> kernel-2.6.20-1.2962.fc6
> ipw3945-ucode-1.14.2-4.at
> ipw3945-1.2.0-18.4.fc6
> ipw3945-kmdl-2.6.22.1-32.fc6-1.2.2-21.fc6
> kernel-2.6.22.1-32.fc6
>

You don't have to install that many things. But as you have installed
them, that does no harm. Remove ieee80211 and ieee80211-kmdl first,
because new kernel contains that. Then remove all 2.6.20 packages that
you don't need. Finally, only these packages left (fuse-kmdl and
kernel-header are irrelevant):

> ipw3945d-1.7.22-4.at
> yum-plugin-kmdl-0.7-9.fc6
> ipw3945-ucode-1.14.2-4.at
> ipw3945-1.2.0-18.4.fc6
> ipw3945-kmdl-2.6.22.1-32.fc6-1.2.2-21.fc6
> kernel-2.6.22.1-32.fc6

Before the analysis, remember all kmdl packages depend on a specific
version of kernel. In the above list, ipw3945-kmdl depends on
kernel-2.6.22.1-32.

If you updated the kernel, then ipw3945-kmdl would become unusable. So
yum is preventing this from happening. If you want to update your
kernel to kernel.i686 2.6.22.2-42.fc6, then you have to be able to
find ipw3945-kmdl of that version-release in your configured yum repo.

Have you tried the builtin iwl3945 driver? Remove ipw3945-kmdl,
Install iwl3945-ucode and you can use the builtin driver, you don't
need to install anything else.



-- 
bbbush ^_^


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]