[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: dhcp not working on machine



On Tue, 2007-08-21 at 16:02 -0700, Antonio Olivares wrote:
> Dear list,
> 
> dhcp is not working on one of my machines.  
> 
> dmesg returns:
> 
> 8139cp: 10/100 PCI Ethernet driver v1.3 (Mar 22, 2004)
> 8139cp 0000:00:0f.0: This (id 10ec:8139 rev 10) is not an 8139C+ compatible chip
> 8139cp 0000:00:0f.0: Try the "8139too" driver instead.
> ACPI: PCI Interrupt 0000:00:10.0[A] -> GSI 19 (level, low) -> IRQ 21
> firewire_ohci: Added fw-ohci device 0000:00:10.0, OHCI version 1.0
> 8139too Fast Ethernet driver 0.9.28
> ACPI: PCI Interrupt 0000:00:0f.0[A] -> GSI 18 (level, low) -> IRQ 22
> eth0: RealTek RTL8139 at 0xde950000, 00:30:1b:3e:d4:b7, IRQ 22
> eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
> 
> 
> What does this mean?
> 
> 8139cp 0000:00:0f.0: Try the "8139too" driver instead.
> 
> I can configure manually, but dhcp was working before.

Try changing your /etc/modprobe.conf file from:

	alias eth0 8139cp

to

	alias eth0 8139too

The log is saying that your hardware isn't compatible with the 8139cp
driver and that you should try the 8139too driver.  And the last bit
of what you included above shows the 8139too driver identifying your
stuff.

----------------------------------------------------------------------
- Rick Stevens, Principal Engineer             rstevens internap com -
- CDN Systems, Internap, Inc.                http://www.internap.com -
-                                                                    -
-       "I'd explain it to you, but your brain might explode."       -
----------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]