[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Using yumex to install new kernel and keep old kernel



Rick Bilonick wrote:
> I'm running FC6. There are two kernels installed: 
> 
> [root localhost ~]# rpm -qva | grep ^kernel
> kernel-2.6.22.1-32.fc6
> kernel-headers-2.6.22.1-32.fc6
> kernel-2.6.20-1.2962.fc6
> 
> The problem is, wireless doesn't work with the newer kernel (2.6.22.1-32
> - something to do with a conflict between wireless-tools and wireless
> extensions and versions which I could not resolve) but it does work with
> the older kernel (2.6.20-1.2962) and all the previous kernels. There is
> a newer kernel available: 2.6.22.2-42. I would like to install
> 2.6.22.2-42 and keep 2.6.20-1.2962. Yumex wants to remove 2962. I've
> tried to remove 32 but when I try this it wants to remove the
> kmod-ndiswrapper that goes with 2962 (because of dependencies - which
> seems weird to me). Is there some way to do this with yumex or yum? Is
> it possible to have all three kernels installed? (I used to be able to
> have many kernels installed in previous versions of FC, not just two.)
> I've also tried unchecking the kernel-module plugin for yumex but this
> seems to have no effect.
> 
> Any advice would be appreciated. I would like to try the new kernel to
> see if wireless will work but I don't want to lose a working kernel.
> 
> Rick B.
> 
This is strange - normally yum will not remove the running kernel
when adding a new kernel. Because I do not reboot this machine very
often, I have had kernels installed and removed that were never
booted, because I was still using the older version because I had
not rebooted.

You may be able to get around the dependency bug by using rpm
instead of yum to remove the kernel. (rpm -e kernel-2.6.22.1-32 or
rpm -e --nodeps kernel-2.6.22.1-32)

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]