[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: error when installing kernel and kernel-headers 2.6.22.4-65.fc7



David Boles wrote:
on 8/25/2007 11:01 AM, Darlene Wallach wrote:
Todd Zullinger wrote:
Darlene Wallach wrote:
Todd,

Thank you, I tried
# yum update kernel-headers.i386

Transaction Check Error:
file /usr/include/linux/netfilter_ipv4/ipt_iprange.h from install of kernel-headers-2.6.22.4-65.fc7 conflicts with file from package kernel-headers-2.6.22.1-41.fc7
Odd.  I updated my system yesterday and it properly pulled in the
newer kernel-headers package.  So I don't think it's a generic problem
with the package or the repos.  But that doesn't help a lot in solving
the issue you're having. ;)

It could help to clean out your yum cache, but that's just a WAG.
Before I emailed regarding my problem, I did
yum clean all and even rebooted

So I guess I'll stick with kernel-2.6.22.1-41.fc7 and
kernel-headers-2.6.22.1-41.fc7
A quick way to work around this would be to remove kernel-headers,
then yum update, and then yum install kernel-headers (if you need it,
that is).


Todd,

You are suggesting I do:
yum remove kernel-headers-2.6.22.1-41.fc7
yum install kernel-headers.i386
yum install kernel.i686

I'm assuming I should install kernel stuff.


I'm not Todd but:

yum update

will offer to update any packages that are available for Fedora 7

-------------------
yum update kernel

will offer to install the new kernel (kernels are always installed, never
updated) *and* to update the kernel-headers package. It will remove the
kernel (yum keeps two kernels installed) that you are not currently using
and it will remove the old kernel-header package. Yum will also write the
new GRUB config. Removing the listing for the removed kernel, adding the
listing for the new kernel, and making the new kernel the default kernel
to boot. To use the new kernel now you will have to reboot.



At first the update demaen failed to install the
kernel-header with the same error message shown
above.

Then I manually tried yum install which failed with
the error message above.

Then I renamed the file, ran yum clean all and tried
yum install which failed again with the error above.

I think Todd's suggestion of removing the old
kernel-header might solve the conflict. Though
I don't know how the
/usr/include/linux/netfilter_ipv4/ipt_iprange.h
was being read from kernel-headers-2.6.22.1-41.fc7

btw, I disabled the install only 2 kernels option.

Darlene Wallach


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]