[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Updated bcm43xx-old-config script (was Re: Need help w/ bcm43xx-mac80211 issues? (ndiswrapper co



On Mon, Aug 27, 2007 at 04:29:25PM +0200, glhere wrote:
> i used the updated script -- thanks to J. Linville who went out of his way to supply -- and can at least now see the device listed in system-config-network.  Yay!
> 
> Now to activate: when I try to activate what system-config-network calls eth1, the message appears that eth1 cannot be activated: please check cable.
> 
> 1. is there some sort of mixup between FC7 using wlan0 and the system-config-tool using eth1? (I know zip to a bit about networking, but don't mind learning more)  Or is this just semantics?

The bcm43xx driver names it's interfaces "ethX", not "wlanX".

> 2. I found a tutorial online that mentions a file /etc/pcmcia/config.opts wherein (they say) the card should be mentioned (it is not).  I also remember an /etc/modprobe.conf file -- I checked there and there is the line, per the new bcm43xx-old script, options bcm43xx fwpostfix=.v3.  I assume that line is similar to adding the alias (that might run something like alias bcm43xx.v3 only better, yes>

Sounds like an old tutorial.  I think you should leave /etc/pcmcia
alone.  You might want "alias eth1 bcm43xx" in /etc/modprobe.conf.

> So, do I need to add anything to the pcmcia file (I have a mini-pci card, so don't think so??) or fix up any other file so the eth1 device can be activated?  Or mebbe I should find a way to get rid of the bcm43xx-mac80211...-.ko files hanging around or the softMAC files from other driver installation tries?

This should not be necessary.

Hth!

John
-- 
John W. Linville
linville redhat com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]