[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fwd: Problem with window program under root



Riggi wrote:
> 
> 
> On 8/26/07, *Mikkel L. Ellertson* <mikkel infinity-ltd com
> <mailto:mikkel infinity-ltd com>> wrote:
> 
> > Dumb question - what version of Fedora are you running? I ask
> > because what you are doing works for me on FC5, FC6 and I think on
> > F7. (I don't remember if I tried it on F7 directly, but I know it
> > worked fine when I did a ssh connection to the F7 box, and su -)
>     
> 
> FC7
> 
> did you read what someone wrote me on forum, I quoted it; and my question is
> how can I add xauthority to root... is cookie only way
> 
> thanks
> 
You will have to read the xauth man page - it shows you most of the
options. You can also disable some of the X security using the xhost
command. For example, running "xhost +localhost" in an xterm will
open access to everyone on the local machine. (This HAS to be run by
a user that can connect to the X server.)

I wonder why you are having this problem. In F7, if I open an xterm,
run "su -" to become root, and then run an X command, it works fine
for me. I am drawing a blank about what to ask to figure out how
your setup is different then the standard setup.

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]