[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

System lockup problem with 7G of memory and PAE kernel - FC7



I have an older dual processor server with 4 Gig of memory that has been running FC5 since it was released. I tried to upgraded to 7 Gig of memory under FC5 but the system locked up in the init phase regardless of what I did. I didn't chase the problem because I intended to upgrade
the OS.

Recently I did upgrade the OS to F 7 and tried the changing the memory to 7 Gig again. Using the standard i686 kernel, it boots and runs correctly, but warns that only 4 Gig of memory will be used and that the PAE kernel was necessary to use the full 7 Gig.

I installed the 2.6.22.4-65.fc7PAE kernel and the system boots correctly, but stops at the init phase. The system is not locked up as it will respond to C-A-Del and reboot. The output at the time of lock up looks like this:

Switching to new root and running Init
Umounting old 	/dev
		/proc
		/sys
exec of init (/sbin/init) failed accessing a corrupted shared library
request_module: runaway loop modprobe binfmt-0397 (repeated 5 times)

I ran the memory test on the system for 8 hours or so and it found and tested all 7 Gig. Also I have booted this system with M$ Advanced server and it finds/uses all 7 Gig so I don't think there's anything wrong with the hardware.

Rebooting with the original i686 kernel works correctly.

Any ideas or suggestions welcome.

Cokey



--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]