[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Boot problems (still)



zephod cfl rr com wrote:
> 
> ----- Original Message ----- 
> From: "Mikkel L. Ellertson" <mikkel infinity-ltd com> 
> Date: Tuesday, February 6, 2007 11:28 pm 
> Subject: Re: Boot problems (still) 
> To: For users of Fedora <fedora-list redhat com> 
> 
>> zephod cfl rr com wrote: 
>>> I reported this problem some time ago but I still cannot boot my 
> FC6 
>>> disk. 
> 
> snip 
> 
>>> Steve 
>>>
> 
>> Dumb question - does your BIOS know about the IDE drive? If not, 
>> then chances are you will not be able to boot from it. You may have 
>> to make space for the /boot directory on the SATA drive. 
> 
> Not a dumb question at all and I think the answer is... maybe. 
> 
> The IDE drive does not show up in the BIOS list of primary or 
> secondary IDE devices but it does show up in the BIOS list of hard 
> drives. Also, this BIOS (ASUS P5G2 Deluxe or something close to that) 
> can present a menu of devices that you can boot from and the IDE drive 
> shows up in that list. This is how I was booting this disk before with 
> FC5. This used to work and when I upgraded to FC6 it appeared to work 
> for a short while. The BIOS hasn't changed but GRUB went from 0.95 to 
> 0.97 in the upgrade. I have been avoiding messing with the Windows 
> dusk since that the only way for me to communicate at the moment. 
> 
>> If your BIOS does know about the IDE drive, running "grub-install 
>> --remap" may help. You may also want to try running "geometry 
>> (hd2,0)" and "geometry (hd3,0)" just in case the BIOS is skipping 
>> numbers when mapping drives. 
> 
> I will try the --remap option. I have already tried hd numbers all the 
> way up to 9 with no luck.
> 
This sounds like the BIOS may not be giving it a number, unless you
boot from it. The fact that Grub does not see it tends to support this.

>> With the drive being /dev/hdk, it sounds like the drive is on a 
>> controller card, and not off the motherboard... Is this the case? 
> 
> You are correct sir! Originally, I could not get the BIOS to see the 
> IDE drive when I connected it to the motherboard so I plugged in an 
> old IDE controller and hooked the drive up to that. This worked fine 
> for ~1yr.
> 
While it was working, were you telling the BIOS to boot from this
drive? If so, then I think you should be telling Grub to use hd0,
and not hd1. At least the BIOS's I have used map the drive that you
boot from as the first hard drive. This was needed by older versions
of Windows that had to boot from the first hard drive. This gets
tricky because you do not get this change of mapping when you boot
from the CD/DVD drive. So the map created when installing/upgrading
from a CD/DVD is not the same as when you tell the BIOS to boot from
the IDE drive instead of the SATA drive.

Now, if you are using the Windows XP boot loader to load Grub, then
you will probably need to update the boot file you created from the
boot record on the IDE drive to reflect the upgraded version of
Grub. This is because the file locations on the drive for stage 2
(or stage 1.5) are hard coded into stage 1, and it is stage 1 that
you copy to Windows. Chances are, the file locations changed in the
upgrade. But part of the old files may still be there.

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]