[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: yum-updatesd is totally broken



On Wed, 2007-02-07 at 09:42 -0500, Kevin H. Hobbs wrote:
> On Wed, 2007-02-07 at 06:55 -0500, fedora-list-request redhat com wrote:
> > Same here...once I did the original yum update, it has worked
> > automatically since then.
> 
> 
> I updated yum-updatesd and yum before my last attempt to run
> yum-updatesd. I don't know if that was before the 2007-Jan-15 update of
> yum-updatesd. For me all it's done is leak a lot of memory, and I don't
> know if it was the fault of yum-updatesd, but my rpm database has become
> corrupted on each computer at least once.

I had an issue on my T20 where the rpm database kept on becoming
corrupted. I finally did a clean install again - and it kept happening
again.

Interestingly, it only happened on my laptop, not my desktop. So I ran
memtest86 on my laptop, and sure enough, I had a bad ram chip.

Replaced the bad ram chip and did a clean install, no rpm database
problems since.

I know bad ram is not the only possible cause of a corrupted RPM
database, but I have not had an RPM database corrupt other than this in
a stable (non test) release of RH/Fedora since before RH 7.2. I did have
issues occasionally in RH 5.1 and 6.0 (don't remember 6.1 or 6.2).

Wait - it also happened in RH 8.0 but that was a few days before my CPU
decided to die, I suspect they were related. I also got a weird gcc
error the day before that CPU died (telling me the compile error should
not have happened and I should report it to GNU gcc list)

Anyway, if you are experience rpm database issues, I would suggest
letting memtest86 run overnight on the box (a few hours is probably
enough to catch it) to at least eliminate that possible hardware issue.

Also, boot off a rescue/knoppix CD and run fsck -f on the filesystem.
I've had filesystem corruption that is caught by unmounting it and
invoking fsck with the -f switch that is not caught by simply
touching /forcefsck

If there is a filesystem problem and your machine passed the memtest86
test, then there may be a disk/cable/controller issue.

I'm not saying your RPM database issue is hardware related, but I would
definitely check it out.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]