[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: videolan






As far as I know, livna and freshrpms are not compatible. Perhaps
that's why you are getting this problem?

It is not properly a question of being compatible. They offer, in general, different versions of the same packages. Sometimes, this does not matter, but if the version of a required shared library is different, then, there is no way...

Freshrpms always uses an embedded ffmpeg for vlc and xine, for instance. Therefore it is not affected when ffmpeg is upgraded. But there are a lot of other dependencies, such as x264, faac, faad, libdvdcss, libdvdread, etc...
 

>From your error messages: "Transaction Check Error:   package
aalib-1.4.0-5.fc6.rf (which is newer than aalib-1.4.0-0.11.rc5.fc6) is
already installed" I get the impression that the newer aalib was
probably installed from freshrpms (hence it ends with rf) as part of
installing xine. And that is conflicting with the older aalib from
livna.

rf means rpmforge. It is from Dries. Nonetheless, aalib has no practical use, and nobody will ever need it. Its version is not important.

I always compile my own version of vlc and mplayer, because I like different options. But this is not necessary. Just choose a repo you like, and install all dependencies. Livna is a good repo, but it is not more compatible to Fedora then other repos, as some people like to say.

--
Paulo Roma Cavalcanti
LCG - UFRJ
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]