[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

rubygems install is missing something



Hi all
I am pretty new to Ruby, thought I would learn a bit. Installed 
everything ruby-related from yum. But whenever I try to use 'gem' the 
following happens... does anyone have this working? 
THANKS

# gem
/usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require': no such file to load -- sources (LoadError)
        
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/source_info_cache.rb:6
        
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/remote_installer.rb:12
        
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
        
from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in 
`require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems.rb:111:in 
`manage_gems'
        from /usr/bin/gem:10


# yum list ruby*
Loading "installonlyn" plugin
Setting up repositories
Reading repository metadata in from local files
Installed Packages
ruby.x86_64                              1.8.5.2-1.fc6          
installed
ruby-activerecord.noarch                 1.15.1-1.fc6           
installed
ruby-activesupport.noarch                1.4.0-1.fc6            
installed
ruby-bdb.x86_64                          0.6.0-1.fc6            
installed
ruby-devel.i386                          1.8.5.2-1.fc6          
installed
ruby-devel.x86_64                        1.8.5.2-1.fc6          
installed
ruby-docs.x86_64                         1.8.5.2-1.fc6          
installed
ruby-fam.x86_64                          0.2.0-3.fc6            
installed
ruby-irb.x86_64                          1.8.5.2-1.fc6          
installed
ruby-libs.x86_64                         1.8.5.2-1.fc6          
installed
ruby-libs.i386                           1.8.5.2-1.fc6          
installed
ruby-mode.x86_64                         1.8.5.2-1.fc6          
installed
ruby-mysql.x86_64                        2.7.1-2.fc6            
installed
ruby-postgres.x86_64                     0.7.1-5.fc6            
installed
ruby-racc.noarch                         1.4.5-2.fc6            
installed
ruby-rdoc.x86_64                         1.8.5.2-1.fc6          
installed
ruby-ri.x86_64                           1.8.5.2-1.fc6          
installed
ruby-sqlite3.x86_64                      1.1.0-6.fc6            
installed
ruby-tcltk.x86_64                        1.8.5.2-1.fc6          
installed
rubygems.noarch                          0.9.1-1.fc6            
installed


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]