[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Is my hard drive thrashed?



I'm using FC6. This morning when I turned on my computer, it booted up fine. I logged in fine. As soon as I logged in, I started Firefox. It seemed to take a long time and never came up. So I tried launching something else from the Gnome taskbar. It was unresponsive. I hit CTRL-ALT-BKSP to log out of X. It went to a text screen and I saw lots of messages about ata1 errors and non-responding ports and stuff like that. After a long while things didn't change, so I turned off the machine and tried booting again. The BIOS couldn't find my hard drive (the only SATA drive on the system). I replaced the drive cable, and after that the BIOS found the hard drive.

When I try booting, I see the following grub message:

GRUB

At this point the computer hangs.

So I booted up the rescue CD. I chrooted to my filesystem and ran grub-install /dev/sda. I had to do this about a month ago (I have no idea why), and that fixed the problem. But this time it did not fix the problem.

My question is, how can I get out of this bind? Is my hard drive trashed, or just the boot record? Or is it something else? When I boot off the rescue CD the hard drive contents appear fine. I just can't get it to boot off my system.

Nothing changed between yesterday except for yum-updating about 78 files including firefox.

Thanks for any help,
Dan


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]