[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Removing duplicate apps after FC6 upgrade from FC5



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Karl Hakmiller wrote:
> On Saturday 17 February 2007, Nigel Henry wrote:
>> On Saturday 17 February 2007 07:20, Karl Hakmiller wrote:
>>> On Saturday 17 February 2007, Sam Varshavchik wrote:
>>>> Karl Hakmiller writes:
>>>>> I just upgraded from FC5 to FC6 and have found a dozen or
>>>>> more apps left in FC6 from the FC5 installation as well as
>>>>> duplicate FC6 applications -- at least that is what Synaptic
>>>>> reports.  I was expecting the first sort of redundancy but
>>>>> not the second. Any suggestions about the best way to go
>>>>> about locating and then deleting the superfluous files of
>>>>> either sort?
>>>> Curious -- can you look in your /root/upgrade.log.  I suspect
>>>> that you'll find that the %post script from most of your
>>>> packages has barfed during the update.  Long standing bug, at
>>>> least since FC 3. Bug 178590.
>>> <snip>
>>>
>>> There were various barfing during upgrade -- scriptlets failing
>>> mostly.
>>>
>>> Viz,
>>>
>>> /usr/bin/update-gdk-pixbuf-loaders: line
>>> 27: /etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No
>>> such file or directory
>>> error: %postun(librsvg2-2.14.2-1.i386) scriptlet failed, exit
>>> status 1 /usr/bin/update-gdk-pixbuf-loaders: line
>>> 27: /etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No
>>> such file or directory
>>> error: %postun(librsvg2-2.14.4-1.fc5.1.i386) scriptlet failed,
>>> exit status 1
>>> Upgrading xmlsec1 - 1.2.9-8.1.i386
>>> Upgrading libXp - 1.0.0-8.i386
>>> Upgrading perl-libwww-perl - 5.805-1.1.1.noarch
>>> Upgrading xmlsec1-nss - 1.2.9-8.1.i386
>>> Upgrading slib - 3a3-2.noarch
>>> Upgrading dbus-sharp - 0.63-6.fc6.i386
>>> Upgrading hal-gnome - 0.5.8.1-4.fc6.i386
>>> /usr/bin/update-gdk-pixbuf-loaders: line
>>> 27: /etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No
>>> such file or directory
>>> error: %postun(librsvg2-2.14.2-1.i386) scriptlet failed, exit
>>> status 1 /usr/bin/update-gdk-pixbuf-loaders: line
>>> 27: /etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No
>>> such file or directory
>>> error: %postun(librsvg2-2.14.4-1.fc5.1.i386) scriptlet failed,
>>> exit status 1
>>> Upgrading pnm2ppa - 1:1.04-13.2.2.i386
>>> Upgrading mpage - 2.5.4-7.1.i386
>>> Upgrading gnome-keyring-manager - 2.16.0-2.fc6.i386
>>> /usr/bin/update-gdk-pixbuf-loaders: line
>>> 27: /etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No
>>> such file or directory
>>> error: %postun(librsvg2-2.14.2-1.i386) scriptlet failed, exit
>>> status 1 /usr/bin/update-gdk-pixbuf-loaders: line
>>> 27: /etc/gtk-2.0/i386-redhat-linux-gnu/gdk-pixbuf.loaders: No
>>> such file or directory
>>> error: %postun(librsvg2-2.14.4-1.fc5.1.i386) scriptlet failed,
>>> exit status 1
>>> (END)
>> That looks like a similar problem I had with a big update for FC5.
>> Here It ended up with 2 versions of librsvg installed, and it
>> proved a bit of a problem to remove the earlier version
>> "librsvg2-2.14.2-1.i386".  With another fresh install of FC5, I
>> updated librsvg before doing any of the other updates, and librsvg
>> upgraded ok, leaving only the newest version. Then I did an apt-get
>> dist-upgrade, and had no problems.
>>
>> I know it's not much help if you've ended up with 2 versions of
>> librsvg, and was a bit of trial and error to get rid of the earlier
>> version.
>>
>> Nigel.
> 
> Two versions of librsvg is but one of my problem duplications.  I also 
> have a double apt, various openoffice modulues, greo, evolution, 
> yelp, seamonkey, and on and on.  I'm just about out of patience with 
> using yum remove <app name> (though that is working once the location 
> is known; apt-get is hopeless because of the double, I assume).  I'll 
> probably just scrub the HD and reinstall FC6.


Karl why do you think, how do you know, that you have more than one version
of some packages installed on your system?


- --

  David
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (MingW32)

iD8DBQFF14fEAO0wNI1X4QERAqO7AJ9YdcCy6QfeC+W8JBeDiM0XxCh57QCgjxXu
LQ4SNuqdada0f0Phy7T4/Ns=
=oNIb
-----END PGP SIGNATURE-----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]