[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: YUM doesn't not work



Yum is still Broken.
Synaptic appears to work OK
I install smart using synaptic; try to run it and get:
[root localhost ~]# smart
Traceback (most recent call last):
 File "/usr/bin/smart", line 27, in ?
   from smart import init, initDistro, initPlugins, initPsyco
ImportError: No module named smart

Is there any way I can get smart or Yum to work without having to reinstall?
thank you in advance for any advice as to what I could try,
- S

On 1/31/07, seba bino <sebas0 gmail com> wrote:
cheers Todd, for the help. I've got quite a few astronomy programs
installed, some of which i received help in building, and so i'm
hoping to pursue it a little more.
I installed python in the default diretory. I didn't use the --prefix
option in the compilation.
Here's what I get when I try to run rpm with --verify

[root localhost ~]# rpm --verify rpm-python
[root localhost ~]# rpm --verify yum
[root localhost ~]# rpm --verify python
....L...   /usr/bin/python
missing     /usr/lib/python2.4/lib-old
missing     /usr/lib/python2.4/lib-old/Para.py
missing     /usr/lib/python2.4/lib-old/Para.pyc
missing     /usr/lib/python2.4/lib-old/Para.pyo
missing     /usr/lib/python2.4/lib-old/addpack.py
missing     /usr/lib/python2.4/lib-old/addpack.pyc
missing     /usr/lib/python2.4/lib-old/addpack.pyo
missing     /usr/lib/python2.4/lib-old/cmp.py
missing     /usr/lib/python2.4/lib-old/cmp.pyc
missing     /usr/lib/python2.4/lib-old/cmp.pyo
missing     /usr/lib/python2.4/lib-old/cmpcache.py
missing     /usr/lib/python2.4/lib-old/cmpcache.pyc
missing     /usr/lib/python2.4/lib-old/cmpcache.pyo
missing     /usr/lib/python2.4/lib-old/codehack.py
missing     /usr/lib/python2.4/lib-old/codehack.pyc
missing     /usr/lib/python2.4/lib-old/codehack.pyo
missing     /usr/lib/python2.4/lib-old/dircmp.py
missing     /usr/lib/python2.4/lib-old/dircmp.pyc
missing     /usr/lib/python2.4/lib-old/dircmp.pyo
missing     /usr/lib/python2.4/lib-old/dump.py
missing     /usr/lib/python2.4/lib-old/dump.pyc
missing     /usr/lib/python2.4/lib-old/dump.pyo
missing     /usr/lib/python2.4/lib-old/find.py
missing     /usr/lib/python2.4/lib-old/find.pyc
missing     /usr/lib/python2.4/lib-old/find.pyo
missing     /usr/lib/python2.4/lib-old/fmt.py
missing     /usr/lib/python2.4/lib-old/fmt.pyc
missing     /usr/lib/python2.4/lib-old/fmt.pyo
missing     /usr/lib/python2.4/lib-old/grep.py
missing     /usr/lib/python2.4/lib-old/grep.pyc
missing     /usr/lib/python2.4/lib-old/grep.pyo
missing     /usr/lib/python2.4/lib-old/lockfile.py
missing     /usr/lib/python2.4/lib-old/lockfile.pyc
missing     /usr/lib/python2.4/lib-old/lockfile.pyo
missing     /usr/lib/python2.4/lib-old/newdir.py
missing     /usr/lib/python2.4/lib-old/newdir.pyc
missing     /usr/lib/python2.4/lib-old/newdir.pyo
missing     /usr/lib/python2.4/lib-old/ni.py
missing     /usr/lib/python2.4/lib-old/ni.pyc
missing     /usr/lib/python2.4/lib-old/ni.pyo
missing     /usr/lib/python2.4/lib-old/packmail.py
missing     /usr/lib/python2.4/lib-old/packmail.pyc
missing     /usr/lib/python2.4/lib-old/packmail.pyo
missing     /usr/lib/python2.4/lib-old/poly.py
missing     /usr/lib/python2.4/lib-old/poly.pyc
missing     /usr/lib/python2.4/lib-old/poly.pyo
missing     /usr/lib/python2.4/lib-old/rand.py
missing     /usr/lib/python2.4/lib-old/rand.pyc
missing     /usr/lib/python2.4/lib-old/rand.pyo
missing     /usr/lib/python2.4/lib-old/tb.py
missing     /usr/lib/python2.4/lib-old/tb.pyc
missing     /usr/lib/python2.4/lib-old/tb.pyo
missing     /usr/lib/python2.4/lib-old/util.py
missing     /usr/lib/python2.4/lib-old/util.pyc
missing     /usr/lib/python2.4/lib-old/util.pyo
missing     /usr/lib/python2.4/lib-old/whatsound.py
missing     /usr/lib/python2.4/lib-old/whatsound.pyc
missing     /usr/lib/python2.4/lib-old/whatsound.pyo
missing     /usr/lib/python2.4/lib-old/zmod.py
missing     /usr/lib/python2.4/lib-old/zmod.pyc
missing     /usr/lib/python2.4/lib-old/zmod.pyo

[root localhost Python-2.5]# rpm --verify rpm
prelink: /bin/rpm: at least one of file's dependencies has changed
since prelinking
S.?.....   /bin/rpm
prelink: /usr/bin/rpm2cpio: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/bin/rpm2cpio
prelink: /usr/lib/rpm/rpmd: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/lib/rpm/rpmd
prelink: /usr/lib/rpm/rpmdb_archive: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_archive
prelink: /usr/lib/rpm/rpmdb_checkpoint: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_checkpoint
prelink: /usr/lib/rpm/rpmdb_deadlock: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_deadlock
prelink: /usr/lib/rpm/rpmdb_dump: at least one of file's dependencies
has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_dump
prelink: /usr/lib/rpm/rpmdb_load: at least one of file's dependencies
has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_load
prelink: /usr/lib/rpm/rpmdb_printlog: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_printlog
prelink: /usr/lib/rpm/rpmdb_recover: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_recover
prelink: /usr/lib/rpm/rpmdb_stat: at least one of file's dependencies
has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_stat
prelink: /usr/lib/rpm/rpmdb_svc: at least one of file's dependencies
has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_svc
prelink: /usr/lib/rpm/rpmdb_upgrade: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_upgrade
prelink: /usr/lib/rpm/rpmdb_verify: at least one of file's
dependencies has changed since prelinking
S.?.....   /usr/lib/rpm/rpmdb_verify
prelink: /usr/lib/rpm/rpmfile: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/lib/rpm/rpmfile
prelink: /usr/lib/rpm/rpmi: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/lib/rpm/rpmi
prelink: /usr/lib/rpm/rpmk: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/lib/rpm/rpmk
prelink: /usr/lib/rpm/rpmq: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/lib/rpm/rpmq

Any ideas as to what I could try ...?
- S

On 1/30/07, Todd Zullinger <tmz pobox com> wrote:
> seba bino wrote:
> > thanks, but this didn't solve it and yum is still broken.
>
> Yum now appears to be broken in a different way than before.  It was
> missing the rpm module last time, now it's missing the yum module.
> That's most likely due to the install of python 2.5.
>
> > [root localhost rpm]# rpm -Uvh rpm-python-4.4.2-32.i386.rpm
> > Preparing...                ###########################################
> > [100%]
> >        package rpm-python-4.4.2-32 is already installed
> >
> > rpm-python*, not python-rpm* appears to be already installed.
>
> Yes, there is no python-rpm package AFAIK.  The python rpm module is
> in the rpm-python package.  You can check if it is installed properly
> using rpm --verify (-V for short):
>
> $ rpm --verify rpm-python
>
> If it returns cleanly and with no output, then all is alright with
> that package and you can turn your attention to something else as the
> problem.  You might want to check out the python and yum packages with
> rpm --verify also.
>
> > I have re-built Python2.5 from tar source but I get "No module named
> > yum."
>
> There are many parts of the system that require python (such as yum)
> and updating python to a new major version isn't something you want to
> embark on unless you're prepared to do a lot of debugging and
> rebuilding of other parts of the system.
>
> > Any ideas would be much appreciated ....
>
> I would suggest trying to backtrack and get your system to the state
> it was in prior to the python 2.5 update.  Did you install that in
> /usr/local or did you overwrite the system python installation in
> /usr?
>
> Is there anything critical on this system or are you just using it to
> play?  If the latter, a re-install will likely be quicker if you're
> not very familiar with rpm and Fedora.
>
> --
> Todd        OpenPGP -> KeyID: 0xBEAF0CE3 | URL: www.pobox.com/~tmz/pgp
> ======================================================================
> Sometimes the majority only means that all the fools are on the same
> side.
>     -- Michael W. Smith
>
>
>
> --
> fedora-list mailing list
> fedora-list redhat com
> To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list
>
>
>



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]