[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Eclipse running out of memory, or..?



On 2/22/07, Frode Petersen <fropeter online no> wrote:
I have a problem that I've tried to figure out, but without much progress.

I run Fedora Eclipse with an UML plugin. Very often Eclipse seems to be
stuck in some sort of loop where the java VM is using appr. 50% CPU
(dual core = 100% of one core?). The result is that Eclipse shuts down
after a few minutes. (This happens with ArgoEclipse and Omondo
EclipseUML Community Edition)

This sounds to me like a bug in the Eclipse distribution you are using or a bug in the UML plugin. You would have better luck asking this question in a forum for the Eclipse distriubtion or plugin. This mail list is for the Fedora Linux distribution. Your problem is definitely not caused by Fedora.

I have found some advice suggesting I should try to increase the VM's
memory, but they use flags with the java... command used to run the
normal Eclipse. I have not figured out how to do this with Fedora Eclipse.

I start Eclipse using a shell script where I set up the environment variables and vm arguments before calling the Eclipse executable.

charlie

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]