[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: VMWare: not seeing USB devices



On 24/02/07, javajunkie <javajunkie koyuru com> wrote:
Hi,
> On FC6 on a Dell laptop I have VMWare server installed, and it runs a
> Windows XP Home Edition VM.

Same here.

Same problem I thought after reading your post but then read more
carefully...

>  Although USB devices (printers, memory
> sticks) work fine in FC6, the VM cannot see them. When I look in
> Removable Media -> USB in VMWare, there is nothing there. I tried with
> my printer, my memory stick, and my Dell Axim x50v. lsusb does in fact
> show the devices.
>
> Note that all these devices work fine in VMWare on a neighboring
> Kubuntu desktop, with one caveat: a USB device is seen only after an
> additional USB device is connected, and only the first device shows.
> That means that if I want to use my USB printer, I must turn on the
> printer, then inset my memory stick. Only then does VM see the printer
> (and it still doesn't see the memory stick). So I know that VMWare has
> problems with USB, but at least it works on the kubuntu desktop.

Ok my fc6 works similarly.  When I give the vm focus and plug in two usb
devices, one will show after I click a warning box (from fc6 I think)
saying the device is in use and will be disconnected before continuing.

I was able to see an sd card from my camera which is all I tried.

Do you have VM  --> settings -->usb controller -->mount new device when
in focus checked (paraphrased that last part)?

Shawn


Shawn, I didn't even have USB Controller under VM  --> Settings. So
that go me thinking, and I added these lines to the VMX file:
usb.present = "TRUE"
usb.generic.autoconnect = "TRUE"

And now USB works!

Thanks for the push in the right direction.

Dotan Cohen

http://what-is-what.com/what_is/linux_distribution.html
http://olnu.com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]