[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC6 ipw3945 on Dell D820 not working. What's the best way?



Brian Millett wrote:
> David Kramer escribĂ­o:
SO I bought this brand new Dell Latitude D820. I've been trying to
get a fully working Linux install on it for weeks. I tried F7, but
the new suspend mechanism doesn't work on this laptop,
>
What BIOS rev do you have? On mine (d820), It suspends after I
> upgraded it to A5.
For F7 to suspend, see
http://people.freedesktop.org/~hughsient/quirk/
> and do not use compiz/beryl.

My BIOS is A6 (from April), and it does not suspend. I spent two whole nights trying different quirk options. They never should have changed the power management software in the state it's in.

I hate that I have this brand new laptop and I have to run an older version of Fedora on it, but I've tried all I can try. Hopefully Fedora 8 will be better.

I added the following init.d script to start ipw3945d at the correct time BEFORE the NetworkManager starts. If the network comes up and
the ipw3945d is not started, then the wireless is not activated.

Your script was very helpful.  Thanks.  More on that later


Paul Johnson wrote:
Your experience is just like mine.  I've made both iwl and ipw drivers
work.  I'd say for getting it going the first time, here's what you
should do. Try ipw3945. That means in
/etc/modules.d/blacklist, you need to add iwl3945 to make sure it does
not load. If it doesn ipw won't work.

I uninstalled the iwl stuff. Nothing I read explicitly said so, but my instincts told me they were mutually exclusive.

Second, turn off NetworkManager, at least temporarily.
/sbin/service NetworkManager stop

I never had it enabled.  What does it do?

Third, Find out if the regulatory deamon runs.  If you type this and
it is running, you should see this (pasted in)

# /sbin/ipw3945d
ipw3945d - regulatory daemon
Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
version: 1.7.22
2007-06-29 10:30:31: ERROR: ipw3945d already running.  If ipw3945d is
not running then you
need to remove '/var/run/ipw3945d.pid' and try again.

Got this problem fixed with Brian Millett's script.

and go through the steps of setting up a new wireless device. The
critical part is the last one, where you put in the wireless server's
name and if you can, set the channel.  That gui has a way to activate
it.  It is the same thing as /sbin/ifup eth1 that you were trying.  I
suspect /sbin/ifup eth1 did not work for you before because the
network scripts were not configured. You can study the output of that
setup by reading the files it creates in
/etc/sysconfig/network-scripts.   Look at ifcg-eth1.  That will be
customized for the current access point.   To use others, I "cp
ifcg-eth ifcfg-othersite" and then edit that file.  Leave the device
as eth1, change the essid. after that, /sbin/ifup othersite does the
trick.

My old laptop is running SUSE. They have a tool called SCPM, System Configuration Profile Manager, that lets you store and retrieve different config files for different environments. I was wondering how you would do this in Fedora. While I'm sure your suggestion isn't the official way it's supposed to be done, that sounds like it would work, and work well and predictably. I'll bring it into work Monday and try that.

> I have never had success with system-config-network when
adding more wlreless points.  Don't bother.

I find system-config-network highly unpredictable. It's the first Fedora program I learned to hate ;)

If that works, then you can consider running NetworkManager again and
launching the nm-applet to have a gui way to do this.

Likewise, the man pages for NetworkManager are about two paragraphs long. I guess I'll have to just save all my config files and try it and see what it does.

Honestly, I've wasted many hours on this and I promise this is the
best, most dependable way to get it started.  I think the secret was
to blacklist iwl3945.  After I did that, everything worked 20000%
better

I sincerely hope this helps

Yes. Everything is working now. But it took the hints posted on no less than three emails to get the whole picture. In addiition to Paul's and Brian's suggestions, I found a third post from a related thread suggesting putting "alias eth1 ipw3945" in /etc/modprobe.conf. I never thought to check for that, because I couldn't imagine a scenario where the install didn't do that for me, but I guess I was wrongt.

Thank you both for your suggestions. I would rather have gotten suspend working in F7 than revoert to FC6, but at least I have Fc6 working, and as soon as I migrate my configuration over from the old laptop, I might even have domestic tranquility again.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]