[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: [Gimp-print-devel] Fwd: Re: I have an update problem.



On Monday 02 July 2007, Todd Denniston wrote:
>Gene Heskett wrote:
>> On Sat, 2007-06-30 at 10:57 -0400, Gene Heskett wrote:
>>> The fedora track record in that
>>> dept. concerning printing is spotty at best.  Printing in general seems
>>> to
>>
>> be
>>
>>> something that sits on the back burner, with a _very_ limited gas supply
>>> (eg priority) at fedora.
>>
>> Gene,
>>
>> Upgrade to Fedora 7, where gutenprint is properly packaged.
>>
>> In Fedora 6, gutenprint was in Extras not Core -- and so had to be made
>> to co-exist with the older gimp-print package. (The discussion of why it
>> was this way has already been had, many times over, on
>> fedora-devel-list.)
>>
>> Tim.
>> */
>>
>> Tim, I don't care to do that just yet, I've had sufficient trouble putting
>> F7 on my lappy to not relish that thought just yet.  This is FC6 now, and
>> will probably remain that way till F8 is out.
>>
>> The primary mistake in the gimp packaging for FC6 is that you hard coded
>> the deps to absolutely require gimp-print, when in fact gimp has _no_
>> dependencies on either gimp-print, or gutenprint.  Both are, for gimp,
>> simply plugins that enable printing.  Gimp has no deps on either, and can
>> do everything available in its menu's without either package being
>> installed.
>
>looking at the spec for gimp-2.2.15-3.fc6.src.rpm (released 28 June 2007),
>there appears in it:
>
>%if 0%{?fedora}%{?rhel} == 0 || 0%{?fedora} >= 7 || 0%{?rhel} >= 6
>%define _enable_gutenprint 0%{!?_without_gutenprint:1}
>%else
>%define _enable_gutenprint 0%{?_with_gutenprint:1}
>%endif
>
>* Wed Jun 13 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.15-2
>- require gutenprint-plugin or gimp-print-plugin (#243593)
>                           ^^^^^^^^^
>* Tue Apr 24 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.14-1
>- version 2.2.14
>- don't BuildRequire gimp-print/gutenprint anymore
>* Mon Mar 26 2007 Nils Philippsen <nphilipp redhat com> - 2:2.2.13-3
>- use gutenprint per default for current development/future distribution
>   versions (Fedora >= 7, RHEL >= 6)
>
>
>Something looks a little screwy with that If to me, for some reason it looks
>like it is doing `%define _enable_gutenprint 0 ` if "fedora >=7"
>
>If you really wanted to you could just brute force (IIRC)
>%define _enable_gutenprint 1
>after that if in the spec, and build gimp yourself.
>Of course then you get to wait for it to build.

I shouldn't have to "enable" either of them, it should use what configure 
finds.  That's broken.

I'll just have to leave the gimp where its at by locking it I guess.  Maybe 
that way I can go back to doing the "update all" stuff.  Now if those deps 
were removed as they should be, then I, nor anyone else would be having a 
problem with running a more "bleeding edge" gutenprint, which is to me not 
the least bit bleeding edge 4 months after its build and install.  To me, the 
newer gutenprint "Just Works(TM)", and I'm not about to replace perfectly 
good code with broken code that's nearly 3 years out of maintainance just 
because somebody in packaging this stuff, can't tell the difference between 
an option and a dependency.  The kindest word I can use is dumb.

-- 
Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
The trouble with a kitten is that
When it grows up, it's always a cat
		-- Ogden Nash.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]