[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Intel ipw3945 wireless stoped working after update to kernel 2.6.20-1.2962



Nelson Escravana (nne) wrote:
> Story:
> Initial setup of the ipw3945 on Fc6, wasn't straight forward,
> but after some googling around, I've figure out that I would
> need to switch my i386 kernel to an i686 so it could match the
> packages available. Initial used atrpms, didn't worked, then
> used freshrpms.... it would eventually started working.
> 
> Problem:
> After my last update to kernel 2.6.20-1.2962 my eth1 just
> disapeard.... no messages on the /var/messages the /sbin/ipw3945d
> when forced to started just complains:
> # /sbin/ipw3945d
> ipw3945d - regulatory daemon
> Copyright (C) 2005-2006 Intel Corporation. All rights reserved.
> version: 1.7.22
> 2007-07-01 17:09:58: ERROR: Could not find Intel PRO/Wireless 3945ABG
> Network Connection
> 
> Ups...
> 
> Solution:
> # cd /var/lib/dkms/ipw3945/1.2.1-1/build
> # make
> # cp ipw3945.ko
> /lib/modules/2.6.20-1.2962.fc6/kernel/drivers/net/wireless/
> # depmod -a
> # service ipw3945d restart
> 
> And got it back to life.
> 
> 
You will have to do this on every kernel update, unless you get the
proper module for your kernel installed from ether atrpms or
freshrpms. You need to match both the arch (i686) and kernel
version. The same module does not work for the standard kernel, and
the ZEN kernel, for example.

You will also want to install the proper yum plugin so that the
kernel in not updated before the module is available. (fedorakmod is
one, and I forget the name of the other...) I run the same module on
my laptop, and it gets installed with the updated kernel without
extra effort on my part.

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]