[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problem with yum after upgrading



 Hello list.

 I did an unsupported upgrade of my system from FC5 -> FC6 -> F7
and now i need unofficial help :)

 Problem is, that my yum is failing when doing bigger things. Bigger means,
that a "yum install xxx" or "yum uninstall yyy" is working as long as there are
no bigger dependencies. When doing something bigger I get an error message
like the following:

########
[root mimas ~]# yum groupupdate Base
Setting up Group Process
fedora                    100% |=========================| 2.1 kB    00:00
updates                   100% |=========================| 1.9 kB    00:00
primary.sqlite.bz2        100% |=========================| 3.8 MB    00:16
Package parted - 1.8.6-4.fc7.i386 already installed and latest version
Package logrotate - 3.7.5-3.1.fc7.i386 already installed and latest version
Package at - 3.1.10-11.fc7.i386 already installed and latest version
Package traceroute - 3:2.0.3-1.1.fc7.i386 already installed and latest version
Package crontabs - 1.10-14.fc7.noarch already installed and latest version
Package bzip2 - 1.0.4-10.fc7.i386 already installed and latest version
Package tmpwatch - 2.9.11-1.i386 already installed and latest version
Package vixie-cron - 4:4.1-82.fc7.i386 already installed and latest version
[...]
Resolving Dependencies
--> Running transaction check
---> Package firstboot-tui.noarch 0:1.4.35-1.fc7 set to be updated
---> Package krb5-workstation.i386 0:1.6.1-2.1.fc7 set to be updated
Traceback (most recent call last):
 File "/usr/bin/yum", line 29, in <module>
   yummain.main(sys.argv[1:])
 File "/usr/share/yum-cli/yummain.py", line 135, in main
   (result, resultmsgs) = base.buildTransaction()
 File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 527,
in buildTransaction
   (rescode, restring) = self.resolveDeps()
 File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 804,
in resolveDeps
   deps = self._mytsCheck()
 File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 774,
in _mytsCheck
   thisneeds = self._checkInstall(txmbr)
 File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 948,
in _checkInstall
   dep = self._provideToPkg(req)
 File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 697,
in _provideToPkg
   for pkgtup in self.rpmdb.whatProvides(r, f, v):
 File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 386, in
whatProvides
   pkgs = self.searchProvides(name)
 File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 145, in
searchProvides
   return self.searchPrco(name, 'provides')
 File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 127, in
searchPrco
   if not result.has_key(po.pkgid):
TypeError: list objects are unhashable
######

 I have already deinstalled and reinstalled yum and python-2.5 but
that didn't help.
I guess I might have some old library somewhere on the system that is
not in the
RPM database, but I didn't find one by now.

 BTW, i did the same upgrade on another system (to be exact a bit more, from
FC4 up to F7) last week and that one is running without any problems.

 Does someone have a hint for me maybe?

 Thanks in advance.

Cheers,
Frank


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]