[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Problems with yum



Hello,

I've just upgraded from FC6 to Fedora7 with a first problem which is solved 
now, as I got to boot from the USB key then the cd-rom, to get rid of 
the "ready" bug some reported earlier.

Now, the problem I have is with yum.
I tried to run "yum update" from my newly upgraded system, and it failed.
I supposed this was caused by the repositories I added to my /etc/yum.conf 
file when I was using my FC6 system, so I decided to remove the files I got 
in the /etc/yum.repo.d directory, and backed up the /etc/yum.conf file. 
Then I removed all files related to yum. Once done, I installed manually, 
the files :
yum-3.2.1-1.fc7
yum-fastestmirror-1.1.5-1.fc7
yum-updatesd-3.2.1-1.fc7
yum-metadata-parser-1.1.0-2.fc7
I thought this would have filled up the yum.repo.d directory with repo 
files, but nope.
So I installed a file in /etc/yum.repo.d directory, I named fedora.repo
In that file I added the following lines :
[fedora]
name=Fedora $releasever - $basearch
baseurl=ftp://fr2.rpmfind.net/linux/1/fedora/updates/$releasever/$basearch/
enabled=1
Now I'm able to update some files on my system but I don't know where to 
find the right repo files or the package that contain all the repos I need.
The command "yum update" fails because of dependencies not found.
I read some messages about plugins for yum, but I don't know how this works.
Help would be appreciated. Thank you. Francois

--


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]