[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Problem with yum after upgrading



2007/7/3, Tony Nelson <tonynelson georgeanelson com>:
>  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 127, in
>searchPrco
>    if not result.has_key(po.pkgid):
>TypeError: list objects are unhashable
>######
>
>  I have already deinstalled and reinstalled yum and python-2.5 but
>that didn't help.
> I guess I might have some old library somewhere on the system that is
>not in the
> RPM database, but I didn't find one by now.
>
>  BTW, i did the same upgrade on another system (to be exact a bit more, from
> FC4 up to F7) last week and that one is running without any problems.
>
>  Does someone have a hint for me maybe?

Bugzilla, I think.  The message "list objects are unhashable" seems like a
bug in yum and shouldn't be caused by doing a yum upgrade.  I note that you
are doing "yum group*" commands, which aren't used so much.  Does a "yum
update" also faile?

 No, I did three updates until the upgrade and all worked fine. But trying a
"yum install krb5-workstation" (which is currently missing in group
base) produces
the same error as above.

 I've already asked the yum mailinglist. I will keep this list also
updated when I get
something useful there.

Cheers,
Frank


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]