[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: More Yum Problems with F7



On 7/8/07, Erich Zigler <ezigler superhero org> wrote:
On Sun, Jul 08, 2007 at 08:50:21AM -0500, Tom Browder wrote:

> Tried to no avail.  Also tried removing and reinstalling yum.  I have
> posted to the yum mailing list but no response yet.
> Isn't there some python expert out there who can interpret that
> exception (the error is repeated below)?
> ==>
> Exception exceptions.AttributeError: "'YumRepository' object has no
> attribute 'sack'" in <bound method YumRepository.__del__ of
> <yum.yumRepo.YumRepository object at 0x9276f8c>> ignored
> <==

I am not a python expert but out of curiosity is there any thing
abnormal in your /etc/yum.repos.d/ ?

My /etc/yum.repos.d are the same as on my linux box at work (which works fine).

BTW, we have another linux box at work in which yum cannot find the
repos, but that is another problem for a later discussion.

When I get home I'm going to try to eliminate the byte-compiled yum
python code in /usr/share/yum-cli [cli: command line interface?]
directory and see if maybe there has been some corruption somehow (but
the removal and reinstallation should have taken care of that,
shouldn't it?  we'll see).  Then I will try to dig a little more into
the code (yuk).

-Tom


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]