[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum / rpm dependency broken in F7 ?



on 7/8/2007 7:55 AM, Tim wrote:
> Tim:
>>> Yes, with kernels too.  The old "it installed i586 instead of i686" bug
>>> is quite a pain to resolve.  The usual rpm -qa kernel query gives no
>>> hint which processor type kernel is installed.  You have to dig a little
>>> deeper to work out why your i686 system is wanting to install an i586
>>> kernel module during some update, and wanting to re-install other
>>> software that's already installed (it wants a different processor
>>> version of the same thing, but doesn't actually say so).
> 
> David Boles:
>> uname -m
>>
>> man uname
> 
> I know about uname, have you seen the signature I've been using for
> quite time, now?  The answer's actually a script output, not boilerplate
> text.

Ok. I stand corrected.

As for "seen the signature"? I ignore fancy signatures.

> But uname only shows the currently running kernel, it doesn't help with
> installed kernels.  e.g. I installed the i686 kernel, and several
> updates to it actually do update it.  But when I tried to install a
> kernel module (that ), it wanted to install an i586
> kernel.

That sounds more like you tried to install the wrong "bloody NVidia thing"
module and it was pulling a dependency i586 kernel. I have to back out
here because I don't have any experience with those "bloody NVidia
thing"s. Don't use them or need them.

Good luck.
-- 

  David

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]