[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: X problems



Jeffrey Ross wrote:
Jeffrey Ross wrote:
having problems with X on Fedora 7, these are problems I did not have
with FC6.

The big problem is X is locking up, the system continues to run and it
accessable via the network, but a CTRL-ALT-BKspace does not restore the
X session.
Does X die and leave whatever was previously displayed on the screen? I
had a problem with an Intel 865G card a long time back. X would actually
abort and the screen would not reset until the Graphics card is reset by
a system reboot.

As X crashed/hung while the screensaver was active, or probably more
correctly coming active, the screen would be blank with just the mouse
pointer on the screen.  I *think* but not 100% positive that X was trying
to restart itself.  The only way I could recover was to reboot the system,
I could not get to any of the virtual screens but ssh'ing into the system
worked fine.

I found in the /var/log/Xorg.0.log.old the following:

(II) AIGLX: Suspending AIGLX clients for VT switch
Error in I830WaitLpRing(), timeout for 2 seconds
pgetbl_ctl: 0x7ef80001 pgetbl_err: 0x0
ipeir: 0 iphdr: bf089b31
LP ring tail: 700 head: 0 len: 1f001 start 0
Err ID (eir): 0 Err Status (esr): 1 Err Mask (emr): ffffffdf
instdone: ffe5fafd instdone_1: fffff
instpm: 0
memmode: 0 instps: 8001e022
HW Status mask (hwstam): fffedffe
IRQ enable (ier): 2 imr: fffe0000 iir: 80
acthd: 2dd8024 dma_fadd_p: 2dd8100
ecoskpd: 307 excc: 0
cache_mode: 6800/180
mi_arb_state: 44
IA_VERTICES_COUNT_QW 0/0
IA_PRIMITIVES_COUNT_QW 0/0
VS_INVOCATION_COUNT_QW 0/0
GS_INVOCATION_COUNT_QW 0/0
GS_PRIMITIVES_COUNT_QW 0/0
CL_INVOCATION_COUNT_QW 0/0
CL_PRIMITIVES_COUNT_QW 0/0
PS_INVOCATION_COUNT_QW 0/0
PS_DEPTH_COUNT_QW 0/0
WIZ_CTL 0
TS_CTL 0  TS_DEBUG_DATA fef7fdf6
TD_CTL 0 / 0
space: 129272 wanted 131064
The space xxx wanted yyy error sounds familiar with one system that I
tried running two different video cards on. The error could have been
from an Intel graphics using one graphics card. Regardless this sounds
like a problem introduced into the newer version of the driver.


FatalError re-entered, aborting
lockup
Did you add lockup or was this part of the excerpt from the log.

That is exactly how it appeared in the log, it appeared to end at the line
"lockup".  Actually the log had at least 2 complete sets of the error
sequence.

The motherboard is an Intel DG965RY with a built in video card lspci
reports the VGA controller as:
00:02.0 VGA compatible controller: Intel Corporation 82G965 Integrated
Graphics Controller (rev 02)

Which driver are you using? (i810 or intel)
at the time I was using the intel driver, I have now switched to the i810
and things seem to be better.  Not quite 100% but much better and livable.
 One of the problems I am having now that I did not have with FC6 is when
using mplayer in a full screen mode I am missing a small area near the
bottom the screen.
I believe one of the screen savers is triggering the bug as it just
started happening after I loaded a bunch of screensavers and set it to
randomly choose one, plus it only happens when the system brings up a
screensaver.
noof was a good one for my testing on an Intel driver where X crashed
but left a residual display on the monitor.

I'll have to give that one a try.

In addition I have noticed that I can not play  video's with mplayer
which by default uses xv (?) unless I specify "-vo x11"  in FC6 I didn't
have this issue.
I think that you might get away with downloading the fc6 version and
reverting using rpm and the --oldpackage argument to see if it is
specifically caused by  changes in the driver.

Not 100% sure which driver/package I need to download but I'll see if I
can identify it.
I'm guessing that F7 is using a modified or new version of the Intel
graphics driver.  Any way to either load the version from FC6 or specify
the equivalent driver in Fedora 7?
Hopefully you only need to revert the driver. File a bug report for it
if the reverting to the older driver helps. Otherwise you might have
problems with some other X package which brings out the bug with the
Intel driver.

Jim





I am having the same issues with a desktop with nvidia driver. I was looking at blaming the nvidia driver but if the same issues with xorg taking up all the processing power is happening with the Intel driver, maybe there is an issue with the Fedora 7 xorg files and how it works with closed source drivers.

I see at least on lockup a day if not more. ssh into the computer and kill the xorg process and the login screen returns.

I don't have enough info to submit a bug report yet.

--
Due to the move to Exchange Server,
   anything that is a priority, please phone.
Robin Laing


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]