[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F7: Can't Start X



On Wed, 2007-07-11 at 21:53 +0100, Dave Cross wrote:
> I wrote a couple of weeks ago, asking for help when the F7
> installation DVD wouldn't boot on my laptop. I didn't get a solution
> to my problem so I installed F7 using the following solution:
> 
> * Install minimal FC6 from installation media
> * yum update to latest versions of everything
> * Install F7 versions of fedora-release and fedora-release-notes rpms
> * yum update to update all rpms to F7

I'm not sure I see the point of the second step.  I'd have thought it
would have been simpler to install 6, update straight to 7, if you had
to.

But I would have tried other methods to install FC7, without first
installing another OS.  Such as copy the FC7 ISO to a partition that you
wouldn't format during install (say a /tmp one), download and burn the
rescue ISO.  Boot from it, start the install as a hard drive install,
where it uses that saved DVD ISO file.

> It took a while, but eventually I was finished and I had a FC6 system
> where all rpms had been updated to their F7 versions. Then I rebooted
> the laptop.
> 
> That's when it went wrong. The boot sequence got as far as starting X
> when it hung. Further investigation shows that I can boot into
> runlevel 3, but it hangs when I run startx. There don't seem to be any
> error logs written.
> 
> During the boot sequence I see a couple of error messages that mention
> not being able to access /dev/hda5. That bothers me as I thought that
> all disk devices were /dev/sdaX in F7.

Post your /etc/fstab file.  Since you mentioned updating from FC6 to
FC7, I'm guessing that some part of your fstab file needs a bit of
tweaking.  It could just the volume label for the swap partition, which
is an arbitrary name that can be altered.

-- 
[tim bigblack ~]$ rm -rfd /*^H^H^H^H^H^H^H^H^H^Huname -ipr
2.6.21-1.3228.fc7 i686 i386

Using FC 4, 5, 6 & 7, plus CentOS 5.  Today, it's FC7.

Don't send private replies to my address, the mailbox is ignored.
I read messages from the public lists.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]