[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: personal file share fc6 not working



On Fri, 2007-07-13 at 22:47 +0100, Ian Malone wrote:
> I'm wondering why personal file sharing isn't working on my
> FC6 machine.  I've got one machine running F7, I can turn
> pfs on and in the Gnome network folder on both the FC6
> and F7 machines the F7 machine will appear.  On the F7
> machine I can open the folder, but on the FC6 machine
> double clicking it does nothing.
> 
> If I enable pfs on the FC6 machine it again appears in the
> network folder on both machines, but double clicking in
> either machine does nothing.  FC6 has all current updates.
> 
> As usual gnome provides no obvious way to find out why;
> where do I start?  Is there some service that should be
> running?

I have wondered how the thing worked (NFS, Samba, something else), so I
left it alone.  I just worked out, now, since you mentioned it, how it's
supposed to do its trick (see below).  I started with the brute force
method of going to edit the Gnome menu, find the personal file sharing
menu item, open it to find out the name of the program it runs, then
researching that.

Since I don't use the zero config stuff, and don't want to on my
network, I haven't actually tried it.  I have played with webdav in the
past, I wasn't too impressed with it.

less /usr/share/doc/gnome-user-share-0.11/README 

gnome-user-share is a small package that binds together various free
software projects to bring easy to use user-level file sharing to the
masses.

The program is meant to run in the background when the user is logged
in, and when file sharing is enabled a webdav server is started that
shares the $HOME/Public folder. The share is then published to all
computers on the local network using mDNS/rendezvous, so that it shows
up in the Network location in Gnome.

The dav server used is apache, so you need that installed. Howl is
used for mDNS support, so you need to have that installed and
mDNSResolver running.

-- 
[tim bigblack ~]$ rm -rfd /*^H^H^H^H^H^H^H^H^H^Huname -ipr
2.6.21-1.3228.fc7 i686 i386

Using FC 4, 5, 6 & 7, plus CentOS 5.  Today, it's FC7.

Don't send private replies to my address, the mailbox is ignored.
I read messages from the public lists.




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]