[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: problem while sending gpg key to mit key server



On Sun, 2007-07-15 at 21:22 +0600, Mustafa Qasim wrote:
> Hello!
>          Sir Tim thaks. It worked I've exported teh ASCII into a txt
> file.But still can't send it. I've tried the pgp.mit.edu web based
> option to pase the ascii there to submit ur key. Now when i finally
> successfully extract the ASCII and paste it on their webpage and hit
> the submit button .. :( it failed. It does the same thing when i try
> to submit through CLI . Try to load for a while n then nothing. :( 
> 
>            Well Sir Mikkel .. my gateway is also my proxy. 10.0.0.1 is
> connected to Internet and also configured as SQUID server so serving
> as both Gateway and proxy for clients. 

Well, if you can overcome the networking issues, one of the following
command lines should work for you.  Perhaps one of them will work around
your networking problem.

gpg --send-keys E35924AA --keyserver hkp://subkeys.pgp.net
gpg --send-keys E35924AA --keyserver mailto:pgp-public-keys keys pgp net
gpg --send-keys E35924AA --keyserver ldap://keyserver.pgp.com

Those are keyserver addresses taken directly from the examples written
in the gpg.conf file.  I would recommend reading it, and the gpg man
file.  This note in the gpg.conf file might be pertinent to you:

# If you have problems connecting to a HKP server through a buggy http
# proxy, you can use keyserver option broken-http-proxy (see below),
# but first you should make sure that you have read the man page
# regarding proxies (keyserver option honor-http-proxy)

Likewise, you can specify alternate ports to connect to.  So if the
usual port is blocked for you, and you can find a keyserver listening on
other ports, you can send it that way.

You shouldn't have to use any particular PGP keyserver, most of them
(supposedly) communicate between themselves.

It does sound like you have a proxy problem, and you'll need to fix
that.  And not just for PGP reasons.  You might want to start another
thread on how to configure your proxy.  Different people might have an
answer, who might be ignoring a gpg thread.

-- 
(This box runs FC5, my others run FC4 & FC6, in case that's
 important to the thread.)

Don't send private replies to my address, the mailbox is ignored.
I read messages from the public lists.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]