[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: problem while sending gpg key to mit key server





On 7/16/07, Tim <ignored_mailbox yahoo com au> wrote:
On Mon, 2007-07-16 at 09:24 +0600, Mustafa Qasim wrote:
> for gpg --send-keys E35924AA --keyserver hkp://subkeys.pgp.net it says
> gpg: no keyserver known (use option --keyserver)  ......  [I am
> already using the --keyserver option ..]

Most peculiar.  Try rearranging the order on the command line (put the
key ID last).  I just tried the opposite (to sending), fetching that
key.  Obviously it'll fail to get *that* key, because it's not on the
server, but I expect a gpg error message that makes sense.

This failed stupidly for me:

[tim gonzales ~]$ gpg --recv-keys E35924AA --keyserver hkp://subkeys.pgp.net
gpg: "--keyserver" not a key ID: skipping
gpg: "hkp://subkeys.pgp.net" not a key ID: skipping
gpg: no keyserver known (use option --keyserver)
gpg: keyserver receive failed: bad URI

It didn't use the keyserver address as server address, but as the key to
retreive.

This failed sensibly for me:

[tim gonzales ~]$ gpg --keyserver hkp://subkeys.pgp.net --recv-keys E35924AA
gpg: requesting key E35924AA from hkp server subkeys.pgp.net
gpgkeys: key E35924AA not found on keyserver
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

It connected, but there wasn't *that* key on their server.  If that key
was there, it would have worked.

Have a go at retreiving a key from the server, to see if that side of
things works.

> m not using LDAP so it none of my business

You don't have to be, *they're* offering it as a communication protocol
to use the keyserver.  Give it a try.

> for mailto command it gaives the same error
> gpg: no keyserver known (use option --keyserver)

I think you might have to send us a copy of your gpg.conf file, but
remove anything private FIRST (also leave a comment so we can see where
you've done that).

--
(This box runs FC5, my others run FC4 & FC6, in case that's
important to the thread.)

Don't send private replies to my address, the mailbox is ignored.
I read messages from the public lists.

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list

in answer to recieve it says --rec-keys is an invalid option...
 wait a minute....Do i need to update the gpg package on my system. it's kind of older version of Ubunto right now at this system from where i m trying to send my key... what is the latest package for gpg command...

and what do u mean by removing private info from gpg.conf...... what part is considered as private for teh key holder?
--
Mustafa Qasim
Lahore, Pakistan
Cell: 0321-6614972
URL: http://www.mustu.info
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]