[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ypbind init script fails



bruce wrote:

why would chkconfig automatically solve his issue(s) regarding nis/ypbind
starting on an intermittent basis?

if there's something else going on behind the scenes, then chkconfig may
have no affect at all...

is this the 1st attempt at running nis/ypbind on the server? are there other
services running on the box? which services?

are there any kind os security services being run on the box that might be
interfering?


This is the first time I have tried to configure NIS and so yes, this is the first time I have tried running ypbind. I killed iptables on the server and client while trying to configure NIS. I found a Red Hat web page on how to secure my NIS and implemented their recommendations. I restarted iptables on both the client and server. I tested it by starting ypbind manually on the client and verifying that ypwhich and ypcat still ran. So I think I have eliminated iptables as the cause of my problem.

In the ypbind init script, there is a couple of functions dealing with selinux. I don't really understand what they are doing. I do not run selinux on my home network. I disabled it during the firstboot script when I installed Fedora on each machine. I tried running the commands in the functions by hand. The results suggested they are not getting in the way but I am not sure. Anyone know how they work?

Any other ideas? I would really like to be able to count on ypbind starting reliably at boot up.

Thanks!

Andrew



-----Original Message-----
From: fedora-list-bounces redhat com
[mailto:fedora-list-bounces redhat com]On Behalf Of Karl Larsen
Sent: Monday, July 16, 2007 4:21 PM
To: For users of Fedora
Subject: Re: ypbind init script fails


Andrew Robinson wrote:
I'm running FC6 on an eMachines laptop. I'm trying to configure NIS
for my growing home network. I seem to be having peculiar problems
with the ypbind init script. When I try to start the init script, it
fails:

[root proteus ~]# /etc/rc.d/init.d/ypbind start
Starting NIS service:                                      [  OK  ]
Binding  NIS service: .........                            [FAILED]
Shutting down NIS service:                                 [  OK  ]

However, I find that if I run the init script with the restart option,
it will often, but not always, succeed:

[root proteus run]# /etc/rc.d/init.d/ypbind restart
Shutting down NIS service:                                 [FAILED]
Starting NIS service:                                      [  OK  ]
Binding  NIS service: ...                                  [  OK  ]

If I start ypbind by itself from a command line, it always succeeds. I
verify the successes and failures with ps, ypwhich and ypcat commands.

Anyone have a clue as to what is going on here? I've been looking for
some indication in some log, but haven't found any. The goal is to get
the init script to succeed on boot up. (The init script gives the same
messages at bootup as it does when run with "start" from the command
line.)

Thanks!

Andrew Robinson

    Try chkconfig ypbind on and when you reboot it will be on and stay on.

Karl

--
fedora-list mailing list
fedora-list redhat com
To unsubscribe: https://www.redhat.com/mailman/listinfo/fedora-list



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]