[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: "No volume control GStreamer plugins and/or devices found"



Dave Cross wrote:
> 
> Luckily, I did have an older version of modules.conf. But they were
> both pretty much the same - at least as far as the Intel sound driver
> was concerned.
> 
> There was one weird thing (that was in both the old and new versions).
> It had this line which I don't really understand:
> 
> remove snd-hda-intel { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || :
> ; }; /sbin/modprobe -r --ignore-remove snd-hda-intel
> 
> I tried it both with and without that line, but it seems to make no
> difference.
> 
What this does is save the ALSA mixer settings when the module is
removed.
> 
>  $  sudo grep hda-intel /var/log/messages.1
>  Jul 21 12:07:52 giles kernel: hda-intel: no codecs initialized
>  Jul 21 12:20:29 giles kernel: hda-intel: no codecs initialized
>  Jul 21 12:28:25 giles kernel: hda-intel: no codecs initialized
> 
> Those times correspond to the reboots I did yesterday trying to get
> this to work.
> 

> Thanks, but I don't really want to spend the next few hours trying
> random options that I don't really understand. Especially given that
> this worked fine under FC6.
> 
>> There are a bunch more model options, but I do not have the
>> reference for them handy right now.
> 
> I've tried Googling for this, but I can't find a reference to the
> snd-hda-intel options. Do you know where I can find them online?
> 
I remember finding a description of the different options on a page
describing the snd-hda-intel driver. I though it was on the ALSA web
site, but I could not find it when I looked today.

http://www.alsa-project.org/

Thinking about this, I remembered that one version of the ALSA
package released had a problem with this chip set. You may want to
run "aplay -l" and see if it generates an error message about a file
not found, or something along that line. With the "no codecs
initialized" error in the logs, I suspect that that may be the case
here. If so, you will have to either downgrad to the older ALSA
package, or build the latest one yourself and see if that helps.

Mikkel
-- 

  Do not meddle in the affairs of dragons,
for thou art crunchy and taste good with Ketchup!

Attachment: signature.asc
Description: OpenPGP digital signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]