[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: switch from Matrox G450 to GeForce 6200/6200TC



> Thank you Chris, it has worked like a charm.
> I checked that the nv rpm package was already installed,
> I turned on kudzu, changed the card, backed up my Xorg.conf file, and
> voila. Reboot, and kudzu didn't ask nothing, but I suppose it did something
> as Xorg.conf has been changed automagically to match my new graphic card,

Good to know it worked.

> Can you give me more info on that.
> I have installed : xorg-x11-drv-nv-1.2.0-4.fc6
> But you say, that with it I don't have 3D support ?
> lspci gives me :
> 01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200]
> (rev a1) (prog-if 00 [VGA])
> 	Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 9
> 	Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
> 	Memory at e0000000 (32-bit, prefetchable) [size=256M]
> 	Memory at d1000000 (32-bit, non-prefetchable) [size=16M]
> 	Capabilities: [60] Power Management version 2
> 	Capabilities: [44] AGP version 3.0
>
> What rpm file do I have to download according to my new card to get such
> support ?

Well, both livna and atrpms have rpms for this. I use livna so will describe 
that, but I suspect atrpms is just as good.

First, you need to add livna to your list of yum repos (if you haven't 
already). The easiest way is to just download the 'repository RPM' from

http://rpm.livna.org/rlowiki/

and install it. Next time you run yum you should find livna in there..

Next, to install the nivida driver just do

 > yum install kmod-nvidia

where kmod stands for kernel module. This will also drag in a few other 
dependencies. 

Thats basically it ! However, whilst you are at it I would recommend a

 > yum install yum-fedorakmod

which will install a nifty little yum plugin, that will prevent yum from 
installing a new kernel for you, until all the kmods you have installed are 
also available for that kernel. Very useful since it protects you from 
situations where a new kernel is installed, but the kmod-nvidia package is 
missing.

Next just reboot. That *should* be it - your xorg.conf should be updated to 
use the 'nvidia' driver and 3D should be available. just run 'glxinfo' to 
check.

Chris


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]