[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC7 yum upgrade



On Thu, 26 Jul 2007 15:32:54 +0300
Catalin Bucur <cata geniusnet ro> wrote:

> Hello,
> 
> 
> I have made an upgrade with yum from FC6 to FC7 on a i686 system with
> IDE drives. Everything worked ok, but I realized after upgrade that in
> /etc/fstab I had /dev/hdX entries instead of LABELs. After reboot I
> got the message:
> 
> Creating root device
> Mounting root filesystem
> mount: could not find filesystem '/dev/root/'
> Setting up other filesystems
> Setting up new root fs
> setuproot: moving /dev failed: No such file or directory
> no fstab.sys, mounting internal defaults
> setuproot: error mounting /proc: No such file or directory
> setuproot: error mounting /sys: No such file or directory
> Switching to new root and running init.
> unmounting old /dev
> unmounting old /proc
> unmounting old /sys
> switchroot: mount failed: No such file or directory
> Kernel panic - not syncing: Attempted to kill init!
> 
> At that point I have tried to make all the modifications necessary to
> boot again with this kernel. Now, the situation looks like:
> 
> -> fdisk
> /dev/sda1               1         126     1012063+  82  Linux swap /
> Solaris /dev/sda2             127        2228    16884314+  83  Linux
> 
> -> blkid
> /dev/sda2: LABEL="Cata" UUID="ebfbf39f-558d-4d30-b143-9e581bf41f77"
> SEC_TYPE="ext2" TYPE="ext3"
> /dev/sda1: TYPE="swap" LABEL="swap"
> 
> -> /etc/fstab
> LABEL=Cata              /                       ext3
> defaults        1 1 sysfs                   /sys
> sysfs   defaults        0 0
> none                    /proc                   proc
> defaults        0 0 none                    /dev/shm
> tmpfs   defaults        0 0
> none                    /dev/pts                devpts
> gid=5,mode=620  0 0 LABEL=swap              swap
> swap    defaults        0 0
> 
> -> /boot/grub/grub.conf
> default=0
> timeout=7
> splashimage=(hd0,1)/boot/grub/splash.xpm.gz
> title Fedora (2.6.21-1.3194.fc7)
> 	root (hd0,1)
> 	kernel /boot/vmlinuz-2.6.21-1.3194.fc7 ro root=LABEL=Cata
> 	initrd /boot/initrd-2.6.21-1.3194.fc7.img
> 
The only difference I see between my F7 setup which works fine and yours
is that I don't have the /boot in front of the kernel and initrd.  I
have a separate /boot partition, though.  

Maybe someone else will spot something.

> -> /boot/grub/device.map
> (fd0)     /dev/fd0
> (hd0)     /dev/sda
> 
> -> I have made another initrd file /boot/initrd-2.6.21-1.3194.fc7.img
> which had the folowing entries:
> resume LABEL=swap
> echo Creating root device.
> mkrootdev -t ext3 -o defaults,ro sda2
> echo Mounting root filesystem.
> mount /sysroot
> echo Setting up other filesystems.
> setuproot
> echo Switching to new root and running init.
> switchroot
> 
> -> at the boot time I saw that ata_piix driver loaded ok:
> <7>ata_piix 0000:00:1f.1: version 2.10ac1
> <7>PCI: Setting latency timer of device 0000:00:1f.1 to 64
> <6>ata1: PATA max UDMA/100 cmd 0x000101f0 ctl 0x000103f6 bmdma
> 0x0001f000 irq 14
> <6>scsi0 : ata_piix
> 
> 
> I even tried to upgrade the system again with FC7 DVD, it was
> installed the kernel, made his initrd, but no success at reboot. With
> FC7 rescue cd it is booting ok, so I do not understand what is the
> problem with his kernel from distribution (which is the default -
> 2.6.21-1.3194.fc7).
> 
> 
> Thank you for your time,


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]