[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Print problems FC7



david walcroft wrote:
Aaron Konstam wrote:
On Thu, 2007-07-26 at 10:10 +1000, david walcroft wrote:
Since updates yesterday including the latest kernel my printer is off line,I have tried the following without success

[david reddwarf ~]$ sudo /usr/share/hplip/setup

HP Linux Imaging and Printing System (ver. 1.7.4a)
Printer/Fax Setup Utility ver. 4.5

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: hplip-gui not installed.  GUI not available. Exiting.
error: PyQt init failed. Reverting to interactive mode.
error: No devices found.
error: Error occured during interactive mode. Exiting.

[david reddwarf ~]$ /usr/share/hplip/probe

HP Linux Imaging and Printing System (ver. 1.7.4a)
Printer Discovery Utility ver. 3.2

Copyright (c) 2001-7 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: No devices found on the 'usb' bus. If this isn't the result you are expecting, warning: check to make sure your devices are properly connected and powered on.

Restarting "service hplip restart" worked but 'print screen' gives me nothing.

 What do I need to do now please
does the
 Thanks   david
I need an explanation of off-line. What does the cups web pages say
about the printer? Does it indicate that you can start the printer? If
it does then start the printer. That worked for me.
--
=======================================================================
May those that love us love us; and those that don't love us, may God
turn their hearts; and if he doesn't turn their hearts, may he turn
their ankles so we'll know them by their limping.
=======================================================================
Aaron Konstam telephone: (210) 656-0355 e-mail: akonstam sbcglobal net

Aaron this from cups web page' $ /sbin/lsusb
Bus 005 Device 003: ID 0409:0059 NEC Corp. HighSpeed Hub
Bus 005 Device 001: ID 0000:0000 Bus 004 Device 001: ID 0000:0000 Bus 003 Device 002: ID 03f0:3611 Hewlett-Packard Bus 003 Device 001: ID 0000:0000 Bus 002 Device 001: ID 0000:0000 Bus 001 Device 001: ID 0000:0000

*Printer State:* stopped, accepting jobs, published

By off-line I mean the printer is not recieving any jobs

Thanks   david


As Aaron said, start the printer from the CUPS page. The printer state should be "idle,accepting jobs, published".

I am puzzled by the fact that /sbin/lsusb could not be found, however. You shouldn't need to sudo to run that command. It does not require root permissions.
I have an HP2410 attached to my F7 system and I'm seeing the following:

$ /sbin/lsusb
Bus 005 Device 003: ID 0409:0059 NEC Corp. HighSpeed Hub
Bus 005 Device 001: ID 0000:0000 Bus 004 Device 001: ID 0000:0000 Bus 003 Device 002: ID 03f0:3611 Hewlett-Packard Bus 003 Device 001: ID 0000:0000 Bus 002 Device 001: ID 0000:0000 Bus 001 Device 001: ID 0000:0000

Is it possible that the problem is with the USB subsystem(s) ?
If you do
   rpm -qa | grep usb
does the usbutils package show up? Any others? This may be drawing you away from the printer problem, but I was drawn to the error message that said "No devices found on the 'usb' bus." I'm approaching my limit of analysis capability here. Hopefully someone else can help enlighten both of us.

~~R


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]