[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Mplayer problem FC7




----- Original Message ----
From: david walcroft <d_j_w46 bigpond net au>
To: For users of Fedora <fedora-list redhat com>
Sent: Friday, July 27, 2007 6:35:35 PM
Subject: Re: Mplayer problem FC7

Tim wrote:
> Tim:
>   
>>> Try changing /dev/hdc to /dev/dvd.  If your system has automatically
>>> set up a device for your DVD drive, that ought to be it.  If not, you
>>> might want to try /dev/sdc, instead (FC7 treats IDE as if it were
>>> SCSI, now).
>>>       
>   
>
> david walcroft:
>   
>> Tim, I've tried changing to /dev/sd0 but as you see it did not work.
>>
>>
>>
>> laying dvd://1.
>> libdvdread: Can't stat /dev/sdc
>> No such file or directory
>> Couldn't open DVD device: /dev/sdc
>> File not found: '1'
>> Failed to open dvd://1.
>>     
>
> Did you try /dev/dvd as well?
>
> e.g. "mplayer /dev/dvd"  or  "mplayer dvd://1 -dvd-device /dev/dvd"
>
>
> This shows /dev/sd0
david reddwarf ~]$ mplayer dvd://1 -dvd-device /dev/sd0
MPlayer 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team
CPU: Intel(R) Celeron(R) CPU 2.66GHz (Family: 15, Model: 4, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Warning unknown option monitor-hfreq at line 107
Warning unknown option monitor-vfreq at line 110
Warning unknown option monitor-dotclock at line 113
Warning unknown option cache-prefill at line 147
This codecs.conf is too old and incompatible with this MPlayer release! 
at line 6
Can't open joystick device /dev/input/js0: No such file or directory
Can't init input joystick
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote 
control.

Playing dvd://1.
libdvdread: Can't stat /dev/sd0
No such file or directory
Couldn't open DVD device: /dev/sd0
File not found: '1'
Failed to open dvd://1.


Exiting... (End of file

Is the command "mplayer dvd://1 -dvd-device /dev/dvd" correct
seeing as mplayer complains about failing to open 'dvd://1' and 'file 
not found 1'

Thanks   david

-- 

David,

/dev/hdc does not work for me either, but /dev/scd0 does work for me

[olivares localhost ~]$ mplayer dvd:// -dvd-device /dev/hdc
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) XP 2700+ (Family: 6, Model: 8, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Playing dvd://.
libdvdread: Can't stat /dev/hdc
No such file or directory
Couldn't open DVD device: /dev/hdc
[file] No filename
Failed to open dvd://.


Exiting... (End of file)
[olivares localhost ~]$ mplayer dvd:// -dvd-device /dev/dvd
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) XP 2700+ (Family: 6, Model: 8, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Playing dvd://.
There are 16 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.
number of audio channels on disk: 0.
number of subtitles on disk: 0
MPEG-PS file format detected.
MPEG: No audio stream found -> no sound.
VIDEO:  MPEG2  720x480  (aspect 2)  29.970 fps  7000.0 kbps (875.0 kbyte/s)
Opening video filter: [screenshot]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 5 -> 4
SwScaler: reducing / aligning filtersize 5 -> 4

SwScaler: BICUBIC scaler, from yuv420p to bgr24 using MMX2
SwScaler: using 4-tap MMX scaler for horizontal luminance scaling
SwScaler: using 4-tap MMX scaler for horizontal chrominance scaling
SwScaler: using n-tap MMX scaler for vertical scaling (BGR)
SwScaler: using MMX2 YV12->BGR24 Converter
SwScaler: 720x480 -> 720x540
VO: [xv] 720x480 => 720x540 Planar YV12 
V:   3.9 113/113 13%  6%  0.0% 0 0 
Exiting... (Quit)
[olivares localhost ~]$ mplayer dvd:// -dvd-device /dev/scd0
MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team
CPU: AMD Athlon(tm) XP 2700+ (Family: 6, Model: 8, Stepping: 1)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Compiled for x86 CPU with extensions: MMX MMX2 3DNow 3DNowEx SSE

Playing dvd://.
There are 16 titles on this DVD.
There are 1 chapters in this DVD title.
There are 1 angles in this DVD title.
number of audio channels on disk: 0.
number of subtitles on disk: 0
MPEG-PS file format detected.
MPEG: No audio stream found -> no sound.
VIDEO:  MPEG2  720x480  (aspect 2)  29.970 fps  7000.0 kbps (875.0 kbyte/s)
Opening video filter: [screenshot]
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred colorspace: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
Try adding the scale filter, e.g. -vf spp,scale instead of -vf spp.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.4.0b
Selected video codec: [mpeg12] vfm: libmpeg2 (MPEG-1 or 2 (libmpeg2))
==========================================================================
Audio: no sound
Starting playback...
VDec: vo config request - 720 x 480 (preferred colorspace: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 1 -> 4
SwScaler: reducing / aligning filtersize 5 -> 4
SwScaler: reducing / aligning filtersize 5 -> 4

SwScaler: BICUBIC scaler, from yuv420p to bgr24 using MMX2
SwScaler: using 4-tap MMX scaler for horizontal luminance scaling
SwScaler: using 4-tap MMX scaler for horizontal chrominance scaling
SwScaler: using n-tap MMX scaler for vertical scaling (BGR)
SwScaler: using MMX2 YV12->BGR24 Converter
SwScaler: 720x480 -> 720x540
VO: [xv] 720x480 => 720x540 Planar YV12 
V:   1.5  40/ 40 17%  6%  0.0% 0 0 
Exiting... (Quit)
[olivares localhost ~]$ 


please try /dev/scd0 and report back success or failure.  Also I notice that your mplayer version 
is 

MPlayer 1.0rc1-4.1.1 (C) 2000-2006 MPlayer Team

where mine is 

MPlayer 1.0rc1-4.1.2 (C) 2000-2006 MPlayer Team

Fedora 7's gcc is at 4.1.2.  I know that Mplayer with 4.1.1 should work, but installing it with 4.1.2 should be a better match.  Have you tried updating mplayer?

Regards,

Antonio 


[olivares localhost ~]$ echo $(date +%Y%m%d%H%M%S)
20070727222053
[olivares localhost ~]$ uname -iprm
2.6.22.1-27.fc7 i686 athlon i386
[olivares localhost ~]$





      ____________________________________________________________________________________
Fussy? Opinionated? Impossible to please? Perfect.  Join Yahoo!'s user panel and lay it on us. http://surveylink.yahoo.com/gmrs/yahoo_panel_invite.asp?a=7 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]